]> git.pld-linux.org Git - packages/perl-Test-LeakTrace.git/blob - perl-Test-LeakTrace.spec
edaca6547b27fa50439ddaa3ae679ef7dae90a16
[packages/perl-Test-LeakTrace.git] / perl-Test-LeakTrace.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Test
6 %define         pnam    LeakTrace
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Test::LeakTrace - tracing memory leaks
9 Summary(pl.UTF-8):      Test::LeakTrace - śledzenie wycieków pamięci
10 Name:           perl-Test-LeakTrace
11 Version:        0.14
12 Release:        5
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Test/GFUJI/Test-LeakTrace-%{version}.tar.gz
17 # Source0-md5:  d53953f442cf782c30f843df677db210
18 URL:            http://search.cpan.org/dist/Test-LeakTrace/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Test-Simple >= 0.62
23 %endif
24 Requires:       perl-dirs >= 4-5
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Test::LeakTrace provides several functions that trace memory leaks.
29 This module scans arenas, the memory allocation system, so it can
30 detect any leaked SVs in given blocks.
31
32 %description -l pl.UTF-8
33 Test::LeakTrace udostępnia kilka funkcji do śledzenia wycieków
34 pamięci. Moduł skanuje areny systemu przydzielania pamięci, przez co
35 może wykryć wycieki SV w podanych blokach.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make} \
44         CC="%{__cc}" \
45         OPTIMIZE="%{rpmcflags}"
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} pure_install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 # packaged as man
56 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Test/LeakTrace/JA.pod
57
58 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
59 cp -a example/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc Changes
67 %{perl_vendorarch}/Test/LeakTrace.pm
68 %{perl_vendorarch}/Test/LeakTrace
69 %dir %{perl_vendorarch}/auto/Test/LeakTrace
70 %attr(755,root,root) %{perl_vendorarch}/auto/Test/LeakTrace/LeakTrace.so
71 %{_mandir}/man3/Test::LeakTrace*.3pm*
72 %{_examplesdir}/%{name}-%{version}
This page took 0.064999 seconds and 2 git commands to generate.