]> git.pld-linux.org Git - packages/perl-Test-LeakTrace.git/blob - perl-Test-LeakTrace.spec
- updated to 0.15
[packages/perl-Test-LeakTrace.git] / perl-Test-LeakTrace.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Test
6 %define         pnam    LeakTrace
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Test::LeakTrace - tracing memory leaks
9 Summary(pl.UTF-8):      Test::LeakTrace - śledzenie wycieków pamięci
10 Name:           perl-Test-LeakTrace
11 Version:        0.15
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Test/Test-LeakTrace-%{version}.tar.gz
17 # Source0-md5:  5eac99e7882970f41886c3e0cec185d8
18 URL:            http://search.cpan.org/dist/Test-LeakTrace/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl(Exporter) >= 5.57
23 BuildRequires:  perl-Test-Simple >= 0.62
24 %endif
25 Requires:       perl-dirs >= 4-5
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Test::LeakTrace provides several functions that trace memory leaks.
30 This module scans arenas, the memory allocation system, so it can
31 detect any leaked SVs in given blocks.
32
33 %description -l pl.UTF-8
34 Test::LeakTrace udostępnia kilka funkcji do śledzenia wycieków
35 pamięci. Moduł skanuje areny systemu przydzielania pamięci, przez co
36 może wykryć wycieki SV w podanych blokach.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make} \
45         CC="%{__cc}" \
46         OPTIMIZE="%{rpmcflags}"
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} pure_install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 # packaged as man
57 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Test/LeakTrace/JA.pod
58
59 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
60 cp -a example/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc Changes README
68 %{perl_vendorarch}/Test/LeakTrace.pm
69 %{perl_vendorarch}/Test/LeakTrace
70 %dir %{perl_vendorarch}/auto/Test/LeakTrace
71 %attr(755,root,root) %{perl_vendorarch}/auto/Test/LeakTrace/LeakTrace.so
72 %{_mandir}/man3/Test::LeakTrace*.3pm*
73 %{_examplesdir}/%{name}-%{version}
This page took 0.103559 seconds and 3 git commands to generate.