]> git.pld-linux.org Git - packages/perl-Test-Fatal.git/blob - perl-Test-Fatal.spec
e2667c91b5387e9256d7fc43099b39763b32833c
[packages/perl-Test-Fatal.git] / perl-Test-Fatal.spec
1 #
2 # Conditional build:
3 %bcond_without  tests # do not perform "make test"
4 #
5 %define         pdir    Test
6 %define         pnam    Fatal
7 Summary:        Test::Fatal - incredibly simple helpers for testing code with exceptions
8 Summary(pl.UTF-8):      Test::Fatal - bardzo proste funkcje pomocnicze do kodu testującego z wyjątkami
9 Name:           perl-Test-Fatal
10 Version:        0.014
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  7954f6d2e3607be10c0fbd69063a3d1b
17 URL:            https://metacpan.org/release/Test-Fatal
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.31
19 BuildRequires:  perl-devel >= 1:5.8.7
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 %if %{with tests}
23 BuildRequires:  perl-Test-Simple >= 0.96
24 BuildRequires:  perl-Try-Tiny >= 0.07
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Test::Fatal is an alternative to the popular Test::Exception. It does
31 much less, but should allow greater flexibility in testing
32 exception-throwing code with about the same amount of typing.
33
34 %description -l pl.UTF-8
35 Test::Fatal to alternatywa dla popularnego Test::Exception. Ten moduł
36 robi znacznie mniej, ale powinien pozwalać na większą elastyczność
37 przy testowaniu kodu rzucającego wyjątki przy mniej więcej tej samej
38 ilości napisanego kodu.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes README
62 %{perl_vendorlib}/Test/Fatal.pm
63 %{_mandir}/man3/Test::Fatal.3pm*
This page took 0.061824 seconds and 2 git commands to generate.