]> git.pld-linux.org Git - packages/perl-Test-Fatal.git/blob - perl-Test-Fatal.spec
6d511bed9cf0808421d2f9d4f79ed641e5523668
[packages/perl-Test-Fatal.git] / perl-Test-Fatal.spec
1 #
2 # Conditional build:
3 %bcond_without  tests # do not perform "make test"
4 #
5 %define         pdir    Test
6 %define         pnam    Fatal
7 Summary:        Test::Fatal - incredibly simple helpers for testing code with exceptions
8 Summary(pl.UTF-8):      Test::Fatal - bardzo proste funkcje pomocnicze do kodu testującego z wyjątkami
9 Name:           perl-Test-Fatal
10 Version:        0.014
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  7954f6d2e3607be10c0fbd69063a3d1b
17 URL:            http://search.cpan.org/dist/Test-Fatal/
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.31
19 BuildRequires:  perl-devel >= 1:5.8.7
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Test-Simple >= 0.96
23 BuildRequires:  perl-Try-Tiny >= 0.07
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Test::Fatal is an alternative to the popular Test::Exception. It does
30 much less, but should allow greater flexibility in testing
31 exception-throwing code with about the same amount of typing.
32
33 %description -l pl.UTF-8
34 Test::Fatal to alternatywa dla popularnego Test::Exception. Ten moduł
35 robi znacznie mniej, ale powinien pozwalać na większą elastyczność
36 przy testowaniu kodu rzucającego wyjątki przy mniej więcej tej samej
37 ilości napisanego kodu.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes README
61 %{perl_vendorlib}/Test/Fatal.pm
62 %{_mandir}/man3/Test::Fatal.3pm*
This page took 0.049482 seconds and 2 git commands to generate.