]> git.pld-linux.org Git - packages/perl-Test-Extreme.git/blob - perl-Test-Extreme.spec
use generic url
[packages/perl-Test-Extreme.git] / perl-Test-Extreme.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Test
6 %define         pnam    Extreme
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Test::Extreme - a perlish unit testing framework
9 Summary(pl.UTF-8):      Test::Extreme - perlowy szkielet do testowania w stylu unit
10 Name:           perl-Test-Extreme
11 Version:        0.12
12 Release:        4
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  008505ccc3d31a46cc89dc5883ba2d14
18 URL:            http://search.cpan.org/dist/Test-Extreme/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Test::Extreme is a perlish port of the xUnit testing framework. It is
26 in the spirit of JUnit, the unit testing framework for Java, by Kent
27 Beck and Erich Gamma. Instead of porting the implementation of JUnit
28 we have ported its spirit to Perl.
29
30 %description -l pl.UTF-8
31 Test::Extreme to perlowy port szkieletu testującego xUnit. Jest w
32 duchu JUnit, szkieletu testowego dla Javy, autorstwa Kenta Becka i
33 Ericha Gammy. Zamiast portowania implementacji Junit został sportowany
34 do Perla jego duch.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %{perl_vendorlib}/%{pdir}/*.pm
58 %{_mandir}/man3/*
This page took 0.06737 seconds and 3 git commands to generate.