]> git.pld-linux.org Git - packages/perl-Test-Extreme.git/blob - perl-Test-Extreme.spec
a8c145cad6850513a2d31d9f5e14f44bbdb7c2af
[packages/perl-Test-Extreme.git] / perl-Test-Extreme.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Test
7 %define         pnam    Extreme
8 Summary:        Test::Extreme - a perlish unit testing framework
9 Summary(pl.UTF-8):      Test::Extreme - perlowy szkielet do testowania w stylu unit
10 Name:           perl-Test-Extreme
11 Version:        0.12
12 Release:        4
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  008505ccc3d31a46cc89dc5883ba2d14
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Test::Extreme is a perlish port of the xUnit testing framework. It is
25 in the spirit of JUnit, the unit testing framework for Java, by Kent
26 Beck and Erich Gamma. Instead of porting the implementation of JUnit
27 we have ported its spirit to Perl.
28
29 %description -l pl.UTF-8
30 Test::Extreme to perlowy port szkieletu testującego xUnit. Jest w
31 duchu JUnit, szkieletu testowego dla Javy, autorstwa Kenta Becka i
32 Ericha Gammy. Zamiast portowania implementacji Junit został sportowany
33 do Perla jego duch.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make}
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %{perl_vendorlib}/%{pdir}/*.pm
57 %{_mandir}/man3/*
This page took 0.102279 seconds and 2 git commands to generate.