]> git.pld-linux.org Git - packages/perl-Test-Differences.git/blob - perl-Test-Differences.spec
93dc90f09b146de85451cda75881bf78ce42c8ed
[packages/perl-Test-Differences.git] / perl-Test-Differences.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Test
7 %define         pnam    Differences
8 Summary:        Test::Differences - test strings and data structures and show differences if not ok
9 Summary(pl.UTF-8):      Test::Differences - kontrola łańcuchów i struktur danych z pokazywaniem różnic
10 Name:           perl-Test-Differences
11 Version:        0.61
12 Release:        1
13 Epoch:          1
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  8728047fbd04a32ffdbbc4304d635eb1
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Text-Diff >= 0.34
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 When the code you're testing returns multiple lines or records and
29 they're just plain wrong, sometimes an equivalent to the Unix diff
30 utility is just what's needed.
31
32 %description -l pl.UTF-8
33 Jeśli testowany kod zwraca wiele linii lub rekordów, które są
34 niepoprawne, czasem przydatny jest odpowiednik uniksowego narzędzia
35 diff.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make}
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes
59 %{perl_vendorlib}/Test/Differences.pm
60 %{_mandir}/man3/Test::Differences.3pm*
This page took 0.049152 seconds and 2 git commands to generate.