]> git.pld-linux.org Git - packages/perl-Test-Block.git/blob - perl-Test-Block.spec
- pl, generic URL
[packages/perl-Test-Block.git] / perl-Test-Block.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Test
7 %define pnam    Block
8 Summary:        Test::Block - Specify fine granularity test plans
9 Summary(pl.UTF-8):      Test::Block - określanie szczegółowych planów testów
10 Name:           perl-Test-Block
11 Version:        0.11
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  386a722947f2c77f6157d1dea0338e35
18 URL:            http://search.cpan.org/dist/Test-Block/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl(Test::Builder::Tester) >= 1.01
23 BuildRequires:  perl-Test-Exception >= 0.15
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This module allows you to specify the number of expected tests at a
30 finer level of granularity than an entire test script. It is built
31 with Test::Builder and plays happily with Test::More and friends.
32
33 %description -l pl.UTF-8
34 Ten moduł pozwala na określanie liczby oczekiwanych testów na poziomie
35 dokładniejszym niż cały skrypt testowy. Jest stworzony w oparciu o
36 Test::Builder i dobrze współpracuje z Test::More oraz podobnymi.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Build.PL \
43         destdir=$RPM_BUILD_ROOT \
44         installdirs=vendor
45 ./Build
46
47 %{?with_tests:./Build test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 ./Build install
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %{perl_vendorlib}/Test/*.pm
61 %{_mandir}/man3/*
This page took 0.079859 seconds and 4 git commands to generate.