]> git.pld-linux.org Git - packages/perl-Test-Block.git/blob - perl-Test-Block.spec
- up to 0.13
[packages/perl-Test-Block.git] / perl-Test-Block.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Test
7 %define pnam    Block
8 Summary:        Test::Block - Specify fine granularity test plans
9 Summary(pl.UTF-8):      Test::Block - określanie szczegółowych planów testów
10 Name:           perl-Test-Block
11 Version:        0.13
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  f4e289f7f2a333983f1e4d578d82f5a3
18 URL:            http://search.cpan.org/dist/Test-Block/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl(Test::Builder::Tester) >= 1.01
23 BuildRequires:  perl-Test-Exception >= 0.15
24 %endif
25 Requires:       perl-base
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _noautoreq      perl(Tie::StdScalar)
30
31 %description
32 This module allows you to specify the number of expected tests at a
33 finer level of granularity than an entire test script. It is built
34 with Test::Builder and plays happily with Test::More and friends.
35
36 %description -l pl.UTF-8
37 Ten moduł pozwala na określanie liczby oczekiwanych testów na poziomie
38 dokładniejszym niż cały skrypt testowy. Jest stworzony w oparciu o
39 Test::Builder i dobrze współpracuje z Test::More oraz podobnymi.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Build.PL \
46         destdir=$RPM_BUILD_ROOT \
47         installdirs=vendor
48 ./Build
49
50 %{?with_tests:./Build test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 ./Build install
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc Changes README
63 %{perl_vendorlib}/Test/*.pm
64 %{_mandir}/man3/*
This page took 0.055859 seconds and 4 git commands to generate.