]> git.pld-linux.org Git - packages/perl-Test-Block.git/blob - perl-Test-Block.spec
- initial, builds here, rel 1
[packages/perl-Test-Block.git] / perl-Test-Block.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Test
7 %define pnam    Block
8 Summary:        Test::Block - Specify fine granularity test plans
9 #Summary(pl):   
10 Name:           perl-Test-Block
11 Version:        0.11
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-authors/id/A/AD/ADIE/Test-Block-0.11.tar.gz
17 # Source0-md5:  386a722947f2c77f6157d1dea0338e35
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(Test::Builder::Tester) >= 1.01
22 BuildRequires:  perl(Test::Exception) >= 0.15
23 BuildRequires:  perl >= 5.6.1
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This module allows you to specify the number of expected tests at a finer level
30 of granularity than an entire test script. It is built with Test::Builder and
31 plays happily with Test::More and friends.
32
33 If you are not already familiar with Test::More now would be the time to go
34 take a look.
35
36 Test::Block supplies a special variable $Plan that you can localize to specify
37 the number of tests in a block.
38
39
40 # %description -l pl
41 # TODO
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45
46 %build
47 %{__perl} Build.PL \
48         destdir=$RPM_BUILD_ROOT \
49         installdirs=vendor
50 ./Build
51
52 %{?with_tests:./Build test}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 ./Build install
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Changes README
65 %{perl_vendorlib}/Test/*.pm
66 #%%{perl_vendorlib}/Test/Block
67 %{_mandir}/man3/*
This page took 0.072815 seconds and 4 git commands to generate.