]> git.pld-linux.org Git - packages/perl-Test-Block.git/blob - perl-Test-Block.spec
- fixed Tie::StdScalar noautoreq; release 3
[packages/perl-Test-Block.git] / perl-Test-Block.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Test
7 %define pnam    Block
8 Summary:        Test::Block - Specify fine granularity test plans
9 Summary(pl.UTF-8):      Test::Block - określanie szczegółowych planów testów
10 Name:           perl-Test-Block
11 Version:        0.13
12 Release:        3
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  f4e289f7f2a333983f1e4d578d82f5a3
18 # https://rt.cpan.org/Ticket/Attachment/1600903/856113/0001-Make-Test-Block-work-with-perl-5.23.8.patch
19 Patch0:         %{name}-perl5.24.patch
20 URL:            http://search.cpan.org/dist/Test-Block/
21 BuildRequires:  perl-Module-Build >= 0.38
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildRequires:  rpmbuild(macros) >= 1.672
25 %if %{with tests}
26 BuildRequires:  perl(Test::Builder) >= 0.17
27 BuildRequires:  perl-Test-Builder-Tester >= 1.01
28 BuildRequires:  perl-Test-Exception >= 0.15
29 BuildRequires:  perl-Test-Simple >= 0.47
30 %endif
31 Requires:       perl-base
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 # provided by Tie::Scalar (perl-base)
36 %define         _noautoreq_perl Tie::StdScalar
37
38 %description
39 This module allows you to specify the number of expected tests at a
40 finer level of granularity than an entire test script. It is built
41 with Test::Builder and plays happily with Test::More and friends.
42
43 %description -l pl.UTF-8
44 Ten moduł pozwala na określanie liczby oczekiwanych testów na poziomie
45 dokładniejszym niż cały skrypt testowy. Jest stworzony w oparciu o
46 Test::Builder i dobrze współpracuje z Test::More oraz podobnymi.
47
48 %prep
49 %setup -q -n %{pdir}-%{pnam}-%{version}
50 %patch0 -p2
51
52 %build
53 %{__perl} Build.PL \
54         destdir=$RPM_BUILD_ROOT \
55         installdirs=vendor
56 ./Build
57
58 %{?with_tests:./Build test}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 ./Build install
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc Changes README
71 %{perl_vendorlib}/Test/Block.pm
72 %{_mandir}/man3/Test::Block.3pm*
This page took 0.071629 seconds and 3 git commands to generate.