]> git.pld-linux.org Git - packages/perl-Test-Block.git/blob - perl-Test-Block.spec
ce5ba01dcba7709dba10e9ac36e25f127d4ea276
[packages/perl-Test-Block.git] / perl-Test-Block.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Test
7 %define pnam    Block
8 Summary:        Test::Block - Specify fine granularity test plans
9 Summary(pl.UTF-8):      Test::Block - określanie szczegółowych planów testów
10 Name:           perl-Test-Block
11 Version:        0.13
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  f4e289f7f2a333983f1e4d578d82f5a3
18 # https://rt.cpan.org/Ticket/Attachment/1600903/856113/0001-Make-Test-Block-work-with-perl-5.23.8.patch
19 Patch0:         %{name}-perl5.24.patch
20 URL:            http://search.cpan.org/dist/Test-Block/
21 BuildRequires:  perl-Module-Build >= 0.38
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 %if %{with tests}
25 BuildRequires:  perl(Test::Builder) >= 0.17
26 BuildRequires:  perl-Test-Builder-Tester >= 1.01
27 BuildRequires:  perl-Test-Exception >= 0.15
28 BuildRequires:  perl-Test-Simple >= 0.47
29 %endif
30 Requires:       perl-base
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         _noautoreq      perl(Tie::StdScalar)
35
36 %description
37 This module allows you to specify the number of expected tests at a
38 finer level of granularity than an entire test script. It is built
39 with Test::Builder and plays happily with Test::More and friends.
40
41 %description -l pl.UTF-8
42 Ten moduł pozwala na określanie liczby oczekiwanych testów na poziomie
43 dokładniejszym niż cały skrypt testowy. Jest stworzony w oparciu o
44 Test::Builder i dobrze współpracuje z Test::More oraz podobnymi.
45
46 %prep
47 %setup -q -n %{pdir}-%{pnam}-%{version}
48 %patch0 -p2
49
50 %build
51 %{__perl} Build.PL \
52         destdir=$RPM_BUILD_ROOT \
53         installdirs=vendor
54 ./Build
55
56 %{?with_tests:./Build test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 ./Build install
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc Changes README
69 %{perl_vendorlib}/Test/Block.pm
70 %{_mandir}/man3/Test::Block.3pm*
This page took 0.035856 seconds and 2 git commands to generate.