]> git.pld-linux.org Git - packages/perl-Term-StatusBar.git/blob - perl-Term-StatusBar.spec
use generic url
[packages/perl-Term-StatusBar.git] / perl-Term-StatusBar.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do perform "make test"
4
5 %define         pdir    Term
6 %define         pnam    StatusBar
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Term::StatusBar - dynamic progress bar
9 Summary(pl.UTF-8):      Term::StatusBar - dynamiczny pasek postępu
10 Name:           perl-Term-StatusBar
11 Version:        1.18
12 Release:        3
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  9203efb3f76e6c4ac986a393b9df657e
18 URL:            http://search.cpan.org/dist/Term-StatusBar/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Term::StatusBar provides an easy way to create a terminal status bar,
26 much like those found in a graphical environment. Term::Size is used
27 to ensure the bar does not extend beyond the terminal's width. All
28 output is sent to STDOUT by default.
29
30 %description -l pl.UTF-8
31 Term::StatusBar udostępnia łatwy sposób tworzenia na terminalu paska
32 stanu podobnego do tych, które można zobaczyć w graficznym środowisku.
33 Używa Term::Size do zapewnienia, żeby pasek nie przekroczył szerokości
34 terminala. Całe wyjście domyślnie jest kierowane na STDOUT.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %{perl_vendorlib}/Term/StatusBar.pm
58 %{_mandir}/man3/*
This page took 0.065984 seconds and 3 git commands to generate.