]> git.pld-linux.org Git - packages/perl-Term-ReadLine-Gnu.git/blob - perl-Term-ReadLine-Gnu.spec
- updated to 1.35
[packages/perl-Term-ReadLine-Gnu.git] / perl-Term-ReadLine-Gnu.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (require a working X connection)
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Term
7 %define         pnam    ReadLine-Gnu
8 Summary:        Term::ReadLine::Gnu - Perl interface for the GNU Readline/History library
9 Summary(pl.UTF-8):      Term::ReadLine::Gnu - perlowy interfejs do biblioteki GNU Readline/History
10 Name:           perl-Term-ReadLine-Gnu
11 Version:        1.35
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Term/HAYASHI/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  514619d68bda1618da61b19d04b5cefe
18 URL:            http://search.cpan.org/dist/Term-ReadLine-Gnu/
19 BuildRequires:  ncurses-devel >= 5.2
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  readline-devel >= 4.2
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 Provides:       perl(Term::ReadLine::Gnu::XS)
24 Obsoletes:      perl-Term-Readline-Gnu
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Term::ReadLine::Gnu Perl module is an implementation of the interface
29 to the GNU Readline Library. This module gives you input line editing
30 facility, input history management facility, word completion facility,
31 etc. It uses the real GNU Readline Library. And this module has the
32 interface with the almost all variables and functions which are
33 documented in the GNU Readline/History Library. So you can program
34 your custom editing function, your custom completion function, and so
35 on with Perl. This may be useful for prototyping before programming
36 with C.
37
38 %description -l pl.UTF-8
39 Moduł Perla Term::ReadLine::Gnu jest implementacją interfejsu do
40 biblioteki GNU Readline. Udostępnia linię wprowadzania tekstu z
41 możliwością edycji, zarządzania historią, automatycznym dopełnianiem
42 itp. Używa biblioteki GNU Readline, ma interfejs do prawie wszystkich
43 zmiennych i funkcji bibliotek Readline i History - można więc
44 oprogramować własne funkcje edycji, dopełniania itp.
45
46 %prep
47 %setup -q -n %{pdir}-%{pnam}-%{version}
48
49 %build
50 %{__perl} Makefile.PL \
51         INSTALLDIRS=vendor
52 %{__make} \
53         CC="%{__cc}" \
54         OPTIMIZE="%{rpmcflags} -DPERL_POLLUTE"
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
61
62 %{__make} install \
63         CC="%{__cc}" \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 rm -f eg/*.orig
67 install eg/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc README
75 %dir %{perl_vendorarch}/Term/ReadLine
76 %{perl_vendorarch}/Term/ReadLine/Gnu*
77 %dir %{perl_vendorarch}/auto/Term/ReadLine
78 %dir %{perl_vendorarch}/auto/Term/ReadLine/Gnu
79 %attr(755,root,root) %{perl_vendorarch}/auto/Term/ReadLine/Gnu/Gnu.so
80 # empty autosplit.ix and *.al files, but requred
81 %dir %{perl_vendorarch}/auto/Term/ReadLine/Gnu/XS
82 %{perl_vendorarch}/auto/Term/ReadLine/Gnu/XS/*.al
83 %{perl_vendorarch}/auto/Term/ReadLine/Gnu/XS/autosplit.ix
84 %{_mandir}/man3/Term::ReadLine::Gnu.3pm*
85 %dir %{_examplesdir}/%{name}-%{version}
86 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*
This page took 0.042451 seconds and 3 git commands to generate.