]> git.pld-linux.org Git - packages/perl-Taint.git/blob - perl-Taint.spec
use generic url
[packages/perl-Taint.git] / perl-Taint.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Taint
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        Taint - Perl utility extensions for tainted data
8 Summary(pl.UTF-8):      Taint - rozszerzenia narzędziowe Perla dla napiętnowanych danych
9 Name:           perl-Taint
10 Version:        0.09
11 Release:        0.1
12 License:        not distributable
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{version}.tar.gz
15 # NoSource0-md5:        e9b23bec1f15ee2f1e1d7309eb04ef92
16 NoSource:       0
17 URL:            http://search.cpan.org/dist/Taint/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Perl has the ability to mark data as 'tainted', as described in
25 perlsec(1). Perl will prevent tainted data from being used for some
26 operations, and you may wish to add such caution to your own code. The
27 routines in this module provide convenient ways to taint data and to
28 check data for taint. To remove the taint from data, use the method
29 described in perlsec(1), or use the make_extractor routine.
30
31 %description -l pl.UTF-8
32 Perl ma możliwość oznaczenia danych jako "napiętnowane" zgodnie z
33 opisem w perlsec(1). Interpreter nie pozwala na używanie
34 napiętnowanych danych w niektórych operacjach, a możemy chcieć dodać
35 taki warunek w swoim kodzie. Funkcje z tego modułu udostępniają
36 wygodne metody do piętnowania danych oraz sprawdzania danych pod tym
37 kątem. Aby usunąć piętno z danych można użyć metody opisanej w
38 perlsec(1) lub wywołać funkcję make_extractor.
39
40 %prep
41 %setup -q -n %{pdir}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make}
47
48 # some tests fail - check again
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc Changes README TODO
63 %{perl_vendorlib}/Taint.pm
64 %{_mandir}/man3/*
This page took 0.086108 seconds and 3 git commands to generate.