]> git.pld-linux.org Git - packages/perl-Sys-Load.git/blob - perl-Sys-Load.spec
cb81e80a77ae0b1b947866062208d81c2cb98e98
[packages/perl-Sys-Load.git] / perl-Sys-Load.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Sys
7 %define         pnam    Load
8 Summary:        Sys::Load - Perl module for getting the current system load and uptime
9 Summary(pl.UTF-8):      Sys::Load - moduł Perla do odczytywania obciążenia systemu i uptime'u
10 Name:           perl-Sys-Load
11 Version:        0.2
12 Release:        15
13 # sae as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Sys/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  370372db0ddbcde3725049157e0bc5ad
18 URL:            http://search.cpan.org/dist/Sys-Load/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 getload() returns 3 elements: representing load averages over the last
25 1, 5 and 15 minutes.  uptime() returns the system uptime in seconds.
26
27 %description -l pl.UTF-8
28 getload() zwraca 3 wartości, reprezentujące średnie obciążenie systemu
29 w ciągu ostatnich 1, 5 i 15 minut. uptime() zwraca uptime systemu w
30 sekundach.
31
32 %prep
33 %setup -q -n %{pdir}-%{pnam}-%{version}
34
35 %build
36 %{__perl} Makefile.PL \
37         INSTALLDIRS=vendor
38 %{__make} \
39         CC="%{__cc}" \
40         OPTIMIZE="%{rpmcflags}"
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Change* README
56 %{perl_vendorarch}/Sys/*.pm
57 %dir %{perl_vendorarch}/auto/Sys/Load
58 %attr(755,root,root) %{perl_vendorarch}/auto/Sys/Load/*.so
59 %{_mandir}/man3/*
This page took 0.05365 seconds and 2 git commands to generate.