]> git.pld-linux.org Git - packages/perl-Sub-Quote.git/blob - perl-Sub-Quote.spec
- macros for perl autodeps
[packages/perl-Sub-Quote.git] / perl-Sub-Quote.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Sub
6 %define         pnam    Quote
7 Summary:        Sub::Quote - Efficient generation of subroutines via string eval
8 Summary(pl.UTF-8):      Sub::Quote - wydajne generowanie podprocedur poprzez ewaluację łańcuchów znaków
9 Name:           perl-Sub-Quote
10 Version:        2.006006
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Sub/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  1bb9caee697bcfa738f419d40505e506
17 URL:            https://metacpan.org/release/Sub-Quote
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  rpmbuild(macros) >= 1.745
21 %if %{with tests}
22 BuildRequires:  perl-Test-Fatal >= 0.003
23 BuildRequires:  perl-Test-Simple >= 0.94
24 %endif
25 Conflicts:      perl-Moo < 2.003000
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This package provides performant ways to generate subroutines from
31 strings.
32
33 %description -l pl.UTF-8
34 Ten pakiet udostępnia wydajne sposoby generowania podprocedur z
35 łańcuchów znaków.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make}
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} pure_install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes README
59 %{perl_vendorlib}/Sub/Defer.pm
60 %{perl_vendorlib}/Sub/Quote.pm
61 %{_mandir}/man3/Sub::Defer.3pm*
62 %{_mandir}/man3/Sub::Quote.3pm*
This page took 0.054962 seconds and 3 git commands to generate.