]> git.pld-linux.org Git - packages/perl-String-Similarity.git/blob - perl-String-Similarity.spec
d46f7e53830f62e76bd955a4d6fdc3a3243eade2
[packages/perl-String-Similarity.git] / perl-String-Similarity.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    String
6 %define         pnam    Similarity
7 Summary:        String::Similarity - calculate the similarity of two strings
8 Summary(pl.UTF-8):      String::Similarity - obliczanie podobieństwa dwóch łańcuchów
9 Name:           perl-String-Similarity
10 Version:        1.04
11 Release:        12
12 # C files say GPL v2+
13 License:        GPL v2
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/String/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  84936c1d393e92680a5d58039dcb9fd9
17 URL:            http://search.cpan.org/dist/String-Similarity/
18 %{?with_tests:BuildRequires:    perl-Encode}
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The 'similarity'-function calculates the similarity index of its two
25 arguments. A value of '0' means that the strings are entirely
26 different. A value of '1' means that the strings are identical.
27 Everything else lies between 0 and 1 and describes the amount of
28 similarity between the strings.
29
30 %description -l pl.UTF-8
31 Funkcja similarity oblicza indeks podobieństwa pomiędzy dwoma
32 parametrami. Wartość '0' oznacza, że łańcuchy są całkowicie różne.
33 Wartość '1' oznacza, że są identyczne. Wszystko inne zawiera się
34 między 0 a 1 i opisuje stopień podobieństwa pomiędzy łańcuchami.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make} \
43         CC="%{__cc}" \
44         OPTIMIZE="%{rpmcflags}"
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %{perl_vendorarch}/String/Similarity.pm
60 %dir %{perl_vendorarch}/auto/String/Similarity
61 %attr(755,root,root) %{perl_vendorarch}/auto/String/Similarity/Similarity.so
62 %{_mandir}/man3/String::Similarity.3pm*
This page took 0.093052 seconds and 2 git commands to generate.