]> git.pld-linux.org Git - packages/perl-Statistics-Frequency.git/blob - perl-Statistics-Frequency.spec
use generic url
[packages/perl-Statistics-Frequency.git] / perl-Statistics-Frequency.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Statistics
6 %define         pnam    Frequency
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Statistics::Frequency - simple counting of elements
9 Summary(pl.UTF-8):      Statistics::Frequency - proste liczenie elementów
10 Name:           perl-Statistics-Frequency
11 Version:        0.03
12 Release:        4
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  b67d54fb3db4787f170f3700e5362417
18 URL:            http://search.cpan.org/dist/Statistics-Frequency/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This is a small module for a small but very common task: counting
26 things, in another words, frequencies. Sure, you can $freq{$elem}++
27 yourself, but what if you need to normalize the frequencies, or what
28 if you have several frequencies you want to combine?
29 Statistics::Frequency to rescue.
30
31 %description -l pl.UTF-8
32 Jest to mały moduł do małego, ale bardzo popularnego zadania:
33 zliczania różnych rzeczy, a innymi słowy, częstotliwości. Oczywiście
34 można robić samemu $freq{$elem}++, ale jeśli potrzebna jest
35 normalizacja częstotliwości, albo kombinacja kilku częstotliwości?
36 Moduł Statistics::Frequency jest ratunkiem.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 #perl Makefile.PL # it's broken: sixsth line prevents from generating man page
43 %{__perl} -MExtUtils::MakeMaker -e 'WriteMakefile(NAME=>"Statistics::Frequency")' \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %{perl_vendorlib}/%{pdir}/*.pm
61 %{_mandir}/man3/*
This page took 0.057445 seconds and 3 git commands to generate.