]> git.pld-linux.org Git - packages/perl-Starlink-AST.git/blob - perl-Starlink-AST.spec
7af6d6b9c25e54f08f11d47509f62c9505f9bdc0
[packages/perl-Starlink-AST.git] / perl-Starlink-AST.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Starlink
6 %define         pnam    AST
7 Summary:        Starlink::AST - Interface to the Starlink AST library
8 Name:           perl-Starlink-AST
9 Version:        1.02
10 Release:        10
11 License:        open_source
12 Group:          Development/Languages/Perl
13 Source0:        http://www.cpan.org/modules/by-authors/id/T/TJ/TJENNESS/Starlink-AST-1.02.tar.gz
14 # Source0-md5:  a5b044630445c2632710107040b70e5a
15 URL:            http://search.cpan.org/dist/Starlink-AST/
16 BuildRequires:  perl-ExtUtils-CBuilder
17 BuildRequires:  perl-Module-Build
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Astro-FITS-CFITSIO
22 BuildRequires:  perl-Test-Number-Delta
23 BuildRequires:  perl-Test-Deep
24 %endif
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         Werror_cflags   %{nil}
28
29 %description
30 Starlink::AST provides a perl wrapper to the Starlink AST library.
31 The Starlink AST library provides facilities for transforming
32 coordinates from one system to another in an object oriented manner.
33 Multiple coordinate frames can be associated with a data set and it is
34 also possible to generate automatic mappings between frames.
35
36 Coordinate frame objects can be imported from FITS headers and from
37 NDF files.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41 %{__mv} t/plot00_pgplot.t t/plot00_pgplot.t-requires-X
42 %{__mv} t/plot00_tk.t t/plot00_tk.t-requires-X
43
44 %build
45 %{__perl} Build.PL \
46         config="optimize=%{rpmcflags}" \
47         destdir=$RPM_BUILD_ROOT \
48         installdirs=vendor
49 ./Build
50
51 %{?with_tests:./Build test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 ./Build install
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc ChangeLog README
64 %dir %{perl_vendorarch}/Starlink
65 %{perl_vendorarch}/Starlink/*.pm
66 %dir %{perl_vendorarch}/Starlink/AST
67 %{perl_vendorarch}/Starlink/AST/*.pm
68 %dir %{perl_vendorarch}/auto/Starlink
69 %dir %{perl_vendorarch}/auto/Starlink/AST
70 %attr(755,root,root) %{perl_vendorarch}/auto/Starlink/AST/*.so
71 %{_mandir}/man3/*
This page took 0.100345 seconds and 2 git commands to generate.