]> git.pld-linux.org Git - packages/perl-Starlink-AST.git/blob - perl-Starlink-AST.spec
- release 5 (by relup.sh)
[packages/perl-Starlink-AST.git] / perl-Starlink-AST.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Starlink
6 %define         pnam    AST
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Starlink::AST - Interface to the Starlink AST library
9 Name:           perl-Starlink-AST
10 Version:        1.02
11 Release:        5
12 License:        open_source
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-authors/id/T/TJ/TJENNESS/Starlink-AST-1.02.tar.gz
15 # Source0-md5:  a5b044630445c2632710107040b70e5a
16 URL:            http://search.cpan.org/dist/Starlink-AST/
17 BuildRequires:  perl-ExtUtils-CBuilder
18 BuildRequires:  perl-Module-Build
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Astro-FITS-CFITSIO
23 BuildRequires:  perl-Test-Number-Delta
24 BuildRequires:  perl-Test-Deep
25 %endif
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         Werror_cflags   %{nil}
29
30 %description
31 Starlink::AST provides a perl wrapper to the Starlink AST library.
32 The Starlink AST library provides facilities for transforming
33 coordinates from one system to another in an object oriented manner.
34 Multiple coordinate frames can be associated with a data set and it is
35 also possible to generate automatic mappings between frames.
36
37 Coordinate frame objects can be imported from FITS headers and from
38 NDF files.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42 %{__mv} t/plot00_pgplot.t t/plot00_pgplot.t-requires-X
43 %{__mv} t/plot00_tk.t t/plot00_tk.t-requires-X
44
45 %build
46 %{__perl} Build.PL \
47         config="optimize=%{rpmcflags}" \
48         destdir=$RPM_BUILD_ROOT \
49         installdirs=vendor
50 ./Build
51
52 %{?with_tests:./Build test}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 ./Build install
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc ChangeLog README
65 %dir %{perl_vendorarch}/Starlink
66 %{perl_vendorarch}/Starlink/*.pm
67 %dir %{perl_vendorarch}/Starlink/AST
68 %{perl_vendorarch}/Starlink/AST/*.pm
69 %dir %{perl_vendorarch}/auto/Starlink
70 %dir %{perl_vendorarch}/auto/Starlink/AST
71 %attr(755,root,root) %{perl_vendorarch}/auto/Starlink/AST/*.so
72 %{_mandir}/man3/*
This page took 0.161165 seconds and 3 git commands to generate.