]> git.pld-linux.org Git - packages/perl-Sort-Key.git/blob - perl-Sort-Key.spec
d68f0e057ca2829290961e711e6ffe2813f7f8db
[packages/perl-Sort-Key.git] / perl-Sort-Key.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Sort
7 %define         pnam    Key
8 Summary:        Sort::Key - interface to sort arrays by one or manipulate calculated keys
9 Summary(pl.UTF-8):      Sort::Key - interfejs do szybkiego sortowania tablic wedÅ‚ug zmiennych kluczy
10 Name:           perl-Sort-Key
11 Version:        1.28
12 Release:        8
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Sort/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  ec9d003d68784a5643815c65124aad18
18 URL:            http://search.cpan.org/dist/Sort-Key/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Sort arrays by one or multiple calculated keys.
25
26 %description -l pl.UTF-8
27 Sortowanie tablic po jednym lub wielu wyliczanych kluczach.
28
29 %prep
30 %setup -q -n %{pdir}-%{pnam}-%{version}
31
32 %build
33 %{__perl} Makefile.PL \
34         INSTALLDIRS=vendor
35 %{__make} \
36         CC="%{__cc}" \
37         OPTIMIZE="%{rpmcflags}"
38
39 %{?with_tests:%{__make} test}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43
44 %{__make} install \
45         DESTDIR=$RPM_BUILD_ROOT
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc README Changes
53 %{perl_vendorarch}/Sort/*.pm
54 %dir %{perl_vendorarch}/Sort
55 %dir %{perl_vendorarch}/Sort/Key
56 %{perl_vendorarch}/Sort/Key/*
57 %dir %{perl_vendorarch}/auto/Sort
58 %dir %{perl_vendorarch}/auto/Sort/Key
59 %attr(755,root,root) %{perl_vendorarch}/auto/Sort/Key/*.so
60 %{_mandir}/man3/*
This page took 0.055756 seconds and 2 git commands to generate.