]> git.pld-linux.org Git - packages/perl-Socket6.git/blob - perl-Socket6.spec
908a0e2c24aa3e4a6fc3070160c993795dadb23d
[packages/perl-Socket6.git] / perl-Socket6.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Socket6
6 %define         pnam    Socket6
7 Summary:        Socket6 Perl module - IPv6-related part of the C socket.h defines and structure manipulators
8 Summary(pl.UTF-8):      Moduł Perla Socket6 - definicje i operacje na strukturach socket.h związanych z IPv6
9 Name:           perl-Socket6
10 Version:        0.29
11 Release:        2
12 License:        BSD-like
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Socket6/%{pnam}-%{version}.tar.gz
15 # Source0-md5:  dab4b2dcc76f81b8bedea72d8fd1bc28
16 URL:            http://search.cpan.org/dist/Socket6/
17 BuildRequires:  rpm-perlprov >= 4.1-13
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 The Socket6 module provides glue routines to the various IPv6
23 functions.
24
25 %description -l pl.UTF-8
26 Moduł Socket6 udostępnia perlowy interfejs do różnych funkcji IPv6.
27
28 %prep
29 %setup -q -n %{pnam}-%{version}
30
31 %build
32 %{__perl} Makefile.PL \
33         INSTALLDIRS=vendor
34 %{__make}
35 pod2man --section=3pm Socket6.pm >Socket6.3pm
36
37 %{?with_tests:%{__make} test}
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 install -d $RPM_BUILD_ROOT%{_mandir}/man3
42
43 %{__make} install \
44         DESTDIR=$RPM_BUILD_ROOT
45 install Socket6.3pm $RPM_BUILD_ROOT%{_mandir}/man3
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc ChangeLog README
53 %{perl_vendorarch}/Socket6.pm
54 %dir %{perl_vendorarch}/auto/Socket6
55 %attr(755,root,root) %{perl_vendorarch}/auto/Socket6/Socket6.so
56 %{_mandir}/man3/Socket6.3pm*
This page took 0.037769 seconds and 2 git commands to generate.