]> git.pld-linux.org Git - packages/perl-Set-String.git/blob - perl-Set-String.spec
use generic url
[packages/perl-Set-String.git] / perl-Set-String.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Set
6 %define         pnam    String
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Set::String - strings as objects with lots of handy methods
9 Summary(pl.UTF-8):      Set::String - łańcuchy jako obiekty z wieloma poręcznymi metodami
10 Name:           perl-Set-String
11 Version:        0.03
12 Release:        4
13 License:        unknown
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  bc5fcfac9d732707418b6860bc7ece7d
17 URL:            http://search.cpan.org/dist/Set-String/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Set-Array >= 0.08
22 BuildRequires:  perl-Want >= 0.05
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Set::String allows you to create strings as objects and use OO-style
29 methods on them. Many convenient methods are provided here that appear
30 in the FAQ's, the Perl Cookbook or posts from comp.lang.perl.misc. In
31 addition, there are Set methods with corresponding (overloaded)
32 operators for the purpose of Set comparison, i.e. +, ==, etc.
33
34 %description -l pl.UTF-8
35 Set::String pozwala na tworzenie łańcuchów jako obiektów i używanie na
36 nich metod. Dostępnych jest wiele wygodnych metod, które podane są w
37 FAQ-ach, Perl Cookbook oraz postach z grupy comp.lang.perl.misc.
38 Dodatkowo są metody Set z odpowiadającymi (przeciążonymi) operatorami
39 do porównywania, np. +, == itd.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47 %{__make}
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %{perl_vendorlib}/%{pdir}/*.pm
63 %{_mandir}/man3/*
This page took 0.064023 seconds and 3 git commands to generate.