]> git.pld-linux.org Git - packages/perl-Set-CrossProduct.git/blob - perl-Set-CrossProduct.spec
27dbafd3d12f2eeb88137dfe8e7c206f2975f91b
[packages/perl-Set-CrossProduct.git] / perl-Set-CrossProduct.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Set
7 %define         pnam    CrossProduct
8 Summary:        Set::CrossProduct Perl module - work with the cross product of two or more sets
9 Summary(pl.UTF-8):      Moduł Perla Set::CrossProduct - ułatwienie pracy z iloczynem kartezjańskim zbiorów
10 Name:           perl-Set-CrossProduct
11 Version:        1.95
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  cdebe89c6c1b0790011eaea47e22af8b
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Given sets S(1), S(2), ..., S(k), each of cardinality n(1), n(2), ...,
25 n(k) respectively, the cross product of the sets is the set CP of
26 ordered tuples such that { <s1, s2, ..., sk> | s1 => S(1), s2 => S(2),
27 ... sk => S(k). }
28
29 %description -l pl.UTF-8
30 Dane są zbiory S(1), S(2), ... S(k), każdy o liczności odpowiednio
31 n(1), n(2), ... n(k). Iloczynem kartezjańskim (produktem) tych zbiorów
32 jest zbiór CP uporządkowanych krotek, takich że { <s1, s2, ... sk> |
33 s1 => S(1), s2 => S(2), ... sk => S(k). }.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make}
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %attr(755,root,root) %{_bindir}/cross
57 %{perl_vendorlib}/%{pdir}/*.pm
58 %{_mandir}/man?/*
This page took 0.339207 seconds and 2 git commands to generate.