]> git.pld-linux.org Git - packages/perl-Sereal-Encoder.git/blob - perl-Sereal-Encoder.spec
rebuild with perl 5.34.0
[packages/perl-Sereal-Encoder.git] / perl-Sereal-Encoder.spec
1 # TODO: system libcsnappy, libminiz?
2 #
3 # Conditional build:
4 %bcond_without  tests           # do not perform "make test"
5
6 %define         pdir    Sereal
7 %define         pnam    Encoder
8 Summary:        Sereal::Encoder - Fast, compact, powerful binary serialization
9 Summary(pl.UTF-8):      Sereal::Encoder - szybka, zwarta, potężna serializacja binarna
10 Name:           perl-Sereal-Encoder
11 Version:        4.018
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-authors/id/Y/YV/YVES/Sereal-Encoder-%{version}.tar.gz
17 # Source0-md5:  702295dcda16a125be9241909390ea98
18 URL:            https://metacpan.org/release/Sereal-Encoder
19 BuildRequires:  perl-ExtUtils-MakeMaker >= 7.0
20 BuildRequires:  perl-ExtUtils-ParseXS >= 2.21
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildRequires:  rpmbuild(macros) >= 1.745
24 BuildRequires:  zstd-devel
25 %if %{with tests}
26 BuildRequires:  perl-Scalar-List-Utils
27 BuildRequires:  perl-Sereal-Decoder >= 4.002
28 BuildRequires:  perl-Test-Deep
29 BuildRequires:  perl-Test-Differences
30 BuildRequires:  perl-Test-LongString
31 BuildRequires:  perl-Test-Simple >= 0.88
32 BuildRequires:  perl-Test-Warn
33 %endif
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 This library implements an efficient, compact-output, and feature-rich
38 serializer using a binary protocol called Sereal. Its sister module
39 Sereal::Decoder implements a decoder for this format. The two are
40 released separately to allow for independent and safer upgrading. If
41 you care greatly about performance, consider reading the
42 Sereal::Performance documentation.
43
44 The Sereal protocol version emitted by this encoder implementation is
45 currently protocol version 3 by default.
46
47 The protocol specification and many other bits of documentation can be
48 found in the github repository at <https://github.com/Sereal/Sereal>.
49
50 %description -l pl.UTF-8
51 Ten moduł implementuje wydajny, mający zwarte wyjście i wiele
52 możliwości, serializer wykorzystujący binary protokół o nazwie Sereal.
53 Siostrzany moduł Sereal::Decoder implementuje dekoder dla tego
54 formatu. Moduły wydawane są osobno, aby umożliwić niezależne i
55 bezpieczniejsze aktualizacje. Informacje na temat wydajności można
56 znaleźć w dokumentacji Sereal::Performance.
57
58 Ta implementacja kodera domyślnie produkuje wyjście zgodne z
59 protokołem Sereal w wersji 3.
60
61 Specyfikację protokołu i inną dokumentację można znaleźć w
62 repozytorium github <https://github.com/Sereal/Sereal>.
63
64 %prep
65 %setup -q -n %{pdir}-%{pnam}-%{version}
66
67 %build
68 %{__perl} Makefile.PL \
69         INSTALLDIRS=vendor
70 %{__make} -j1 \
71         CC="%{__cc}" \
72         OPTIMIZE="%{rpmcflags}"
73
74 %{?with_tests:%{__make} test}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 %{__make} pure_install \
79         DESTDIR=$RPM_BUILD_ROOT
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %files
85 %defattr(644,root,root,755)
86 %doc Changes
87 %dir %{perl_vendorarch}/Sereal
88 %{perl_vendorarch}/Sereal/Encoder.pm
89 %dir %{perl_vendorarch}/Sereal/Encoder
90 %{perl_vendorarch}/Sereal/Encoder/*.pm
91 %dir %{perl_vendorarch}/auto/Sereal
92 %dir %{perl_vendorarch}/auto/Sereal/Encoder
93 %attr(755,root,root) %{perl_vendorarch}/auto/Sereal/Encoder/Encoder.so
94 %{_mandir}/man3/Sereal::Encoder.3pm*
This page took 0.112372 seconds and 3 git commands to generate.