]> git.pld-linux.org Git - packages/perl-Sereal-Decoder.git/blob - perl-Sereal-Decoder.spec
- release 3 (by relup.sh)
[packages/perl-Sereal-Decoder.git] / perl-Sereal-Decoder.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Sereal
6 %define         pnam    Decoder
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Sereal::Decoder - Fast, compact, powerful binary deserialization
9 Name:           perl-Sereal-Decoder
10 Version:        3.002
11 Release:        3
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/Y/YV/YVES/Sereal-Decoder-%{version}.tar.gz
16 # Source0-md5:  c26033b258dc3ee2e4e485f7293ccb63
17 URL:            http://search.cpan.org/dist/Sereal-Decoder/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(Test::LongString)
22 BuildRequires:  perl-Test-Warn
23 %endif
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This library implements a deserializer for an efficient,
28 compact-output, and feature-rich binary protocol called Sereal. Its
29 sister module Sereal::Encoder implements an encoder for this format.
30 The two are released separately to allow for independent and safer
31 upgrading.
32
33 The Sereal protocol versions that are compatible with this decoder
34 implementation are currently protocol versions 1, 2, and 3. As it
35 stands, it will refuse to attempt to decode future versions of the
36 protocol, but if necessary there is likely going to be an option to
37 decode the parts of the input that are compatible with version 3 of
38 the protocol. The protocol was designed to allow for this.
39
40 The protocol specification and many other bits of documentation can be
41 found in the github repository. Right now, the specification is at
42 https://github.com/Sereal/Sereal/blob/master/sereal_spec.pod, there is
43 a discussion of the design objectives in
44 https://github.com/Sereal/Sereal/blob/master/README.pod, and the
45 output of our benchmarks can be seen at
46 https://github.com/Sereal/Sereal/wiki/Sereal-Comparison-Graphs.
47
48 %prep
49 %setup -q -n %{pdir}-%{pnam}-%{version}
50
51 %build
52 %{__perl} Makefile.PL \
53         INSTALLDIRS=vendor
54 %{__make} \
55         CC="%{__cc}" \
56         OPTIMIZE="%{rpmcflags}"
57
58 %{?with_tests:%{__make} test}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 %{__make} pure_install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc Changes
71 %dir %{perl_vendorarch}/Sereal
72 %{perl_vendorarch}/Sereal/*.pm
73 %dir %{perl_vendorarch}/Sereal/Decoder
74 %{perl_vendorarch}/Sereal/Decoder/*.pm
75 %dir %{perl_vendorarch}/auto/Sereal
76 %dir %{perl_vendorarch}/auto/Sereal/Decoder
77 %attr(755,root,root) %{perl_vendorarch}/auto/Sereal/Decoder/*.so
78 %{_mandir}/man3/*
This page took 0.056719 seconds and 3 git commands to generate.