]> git.pld-linux.org Git - packages/perl-Sendmail-PMilter.git/blob - perl-Sendmail-PMilter.spec
7a06efc874556f88d5df4be00da4a601cc940973
[packages/perl-Sendmail-PMilter.git] / perl-Sendmail-PMilter.spec
1 #
2 %bcond_without  tests           # do not perform "make test"
3
4 %include        /usr/lib/rpm/macros.perl
5 %define pdir    Sendmail
6 %define pnam    PMilter
7 Summary:        Sendmail::PMilter - Perl binding of Sendmail Milter protocol
8 Summary(pl):    Sendmail::PMilter - moduł Perla do obsługi protokołu Milter
9 Name:           perl-Sendmail-PMilter
10 Version:        1.00
11 Release:        1
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-authors/id/A/AV/AVAR/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  18f8fd3b69ef98014a1a5d55fbefd3d9
16 BuildRequires:  perl-devel >= 1:5.8.0
17 BuildRequires:  rpm-perlprov >= 4.1-13
18 BuildRequires:  sendmail-devel >= 8.13.6-3.1
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Sendmail::PMilter is a mail filtering API implementing the Sendmail
24 milter protocol in pure Perl. This allows Sendmail servers (and
25 perhaps other MTAs implementing milter) to filter and modify mail in
26 transit during the SMTP connection, all in Perl.
27
28 It should be noted that PMilter 0.90 and later is NOT compatible with
29 scripts written for PMilter 0.5 and earlier. The API has been reworked
30 significantly, and the enhanced APIs and rule logic provided by
31 PMilter 0.5 and earlier has been factored out for inclusion in a
32 separate package to be called Mail::Milter.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 PERL_MM_USE_DEFAULT=1 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make}
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
51 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes doc README
59 %{perl_vendorlib}/Sendmail/*.pm
60 %{perl_vendorlib}/Sendmail/PMilter
61 %{_mandir}/man3/*
62 %{_examplesdir}/%{name}-%{version}
This page took 0.046495 seconds and 2 git commands to generate.