]> git.pld-linux.org Git - packages/perl-Sendmail-PMilter.git/blob - perl-Sendmail-PMilter.spec
use generic url
[packages/perl-Sendmail-PMilter.git] / perl-Sendmail-PMilter.spec
1 #
2 %bcond_without  tests           # do not perform "make test"
3
4 %define pdir    Sendmail
5 %define pnam    PMilter
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        Sendmail::PMilter - Perl binding of Sendmail Milter protocol
8 Summary(pl):    Sendmail::PMilter - moduł Perla do obsługi protokołu Milter
9 Name:           perl-Sendmail-PMilter
10 Version:        1.00
11 Release:        1
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-authors/id/A/AV/AVAR/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  18f8fd3b69ef98014a1a5d55fbefd3d9
16 URL:            http://search.cpan.org/dist/Sendmail-PMilter/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRequires:  sendmail-devel >= 8.13.6-3.1
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Sendmail::PMilter is a mail filtering API implementing the Sendmail
25 milter protocol in pure Perl. This allows Sendmail servers (and
26 perhaps other MTAs implementing milter) to filter and modify mail in
27 transit during the SMTP connection, all in Perl.
28
29 It should be noted that PMilter 0.90 and later is NOT compatible with
30 scripts written for PMilter 0.5 and earlier. The API has been reworked
31 significantly, and the enhanced APIs and rule logic provided by
32 PMilter 0.5 and earlier has been factored out for inclusion in a
33 separate package to be called Mail::Milter.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 PERL_MM_USE_DEFAULT=1 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make}
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
52 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes doc README
60 %{perl_vendorlib}/Sendmail/*.pm
61 %{perl_vendorlib}/Sendmail/PMilter
62 %{_mandir}/man3/*
63 %{_examplesdir}/%{name}-%{version}
This page took 0.045872 seconds and 3 git commands to generate.