]> git.pld-linux.org Git - packages/perl-Schedule-At.git/blob - perl-Schedule-At.spec
use generic url
[packages/perl-Schedule-At.git] / perl-Schedule-At.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test"
4                         # need access to working atd
5
6 %define         pdir    Schedule
7 %define         pnam    At
8 %include        /usr/lib/rpm/macros.perl
9 Summary:        Schedule::At - an OS independent interface to 'at' UNIX command
10 Summary(pl.UTF-8):      Schedule::At - niezależny od platformy interfejs do polecenia 'at'
11 Name:           perl-Schedule-At
12 Version:        1.14
13 Release:        1
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  6f575bbce3db7a77ac29d9b339918e69
19 URL:            http://search.cpan.org/dist/Schedule-At/
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This modules provides an OS independent interface to 'at', the UNIX
27 command that allows you to execute commands at a specified time.
28
29 %description -l pl.UTF-8
30 Schedule::At udostępnia niezależny od platformy interfejs do 'at',
31 uniksowego polecenia, które pozwala na wykonanie komendy o określonym
32 czasie.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make}
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes README
56 %{perl_vendorlib}/Schedule/At.pm
57 %{_mandir}/man3/*
This page took 0.045492 seconds and 3 git commands to generate.