]> git.pld-linux.org Git - packages/perl-SVG-Parser.git/blob - perl-SVG-Parser.spec
use generic url
[packages/perl-SVG-Parser.git] / perl-SVG-Parser.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    SVG
6 %define         pnam    Parser
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        SVG::Parser - converts SVG XML documents into SVG objects
9 Summary(pl.UTF-8):      SVG::Parser - konwersja dokumentów SVG XML do obiektów SVG
10 Name:           perl-SVG-Parser
11 Version:        1.03
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  58e1f95faede185edf0657abc443f668
18 URL:            http://search.cpan.org/dist/SVG-Parser/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-SVG >= 2.0
23 BuildRequires:  perl-XML-Parser
24 BuildRequires:  perl-XML-SAX
25 %endif
26 Requires:       perl-SVG >= 2.0
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 SVG::Parser is an XML parser that converts SVG XML documents into SVG
32 objects that may then be manipulated by the SVG module before being
33 regenerated into XML. It will work using any installed Expat or SAX
34 parser, and may be given preferred list of parsers to try; the first
35 to load successfully will be used.
36
37 %description -l pl.UTF-8
38 SVG::Parser to analizator XML-a konwertujący dokumenty SVG XML na
39 obiekty SVG, którymi można manipulować przy użyciu modułu SVG przed
40 ponownym przekształceniem na XML. Moduł działa z dowolnym
41 zainstalowanym analizatorem Expat lub SAX, można podać listę
42 preferowanych analizatorów - zostanie użyty pierwszy, który uda się
43 załadować.
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-%{version}
47
48 %build
49 %{__perl} Build.PL \
50         destdir=$RPM_BUILD_ROOT \
51         installdirs=vendor
52 ./Build
53
54 %{?with_tests:./Build test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 ./Build install
60
61 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
62 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc README
70 %{perl_vendorlib}/SVG/Parser.pm
71 %{perl_vendorlib}/SVG/Parser
72 %{_mandir}/man3/*
73 %{_examplesdir}/%{name}-%{version}
This page took 0.138913 seconds and 3 git commands to generate.