]> git.pld-linux.org Git - packages/perl-SQL-Translator.git/blob - perl-SQL-Translator.spec
59780dc58d72d8c4fc8a51275668de6e012378c0
[packages/perl-SQL-Translator.git] / perl-SQL-Translator.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    SQL
7 %define pnam    Translator
8 Summary:        SQL::Translator - manipulate structure data definitions (database schemas)
9 Summary(pl):    SQL::Translator - manipulowanie definicjami struktur danych (schematami baz danych)
10 Name:           perl-SQL-Translator
11 Version:        0.06
12 Release:        1
13 License:        GPL v2
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  e7aae659a682ddbb46bbd6b2c15a4b6e
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl-Class-Base
21 BuildRequires:  perl-Parse-RecDescent >= 1.94
22 BuildRequires:  perl-Pod-Parser
23 BuildRequires:  perl-Template-Toolkit >= 2.1
24 BuildRequires:  perl-Text-RecordParser
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 SQL::Translator is a group of Perl modules that manipulate structure
31 data definitions (mostly database schemas) in interesting ways, such
32 as converting among different dialects of CREATE syntax (e.g.,
33 MySQL-to-Oracle), visualizations of schemas (pseudo-ER diagrams
34 GraphViz or GD), automatic code generation (using Class::DBI),
35 converting non-RDBMS files to SQL schemas (xSV text files, Excel
36 spreadsheets), serializing parsed schemas (via Storable, YAML and
37 XML), creating documentation (HTML and POD), and more. We also have
38 the ability to talk directly to a database through DBI to query for
39 the structures of several databases.
40
41 # %description -l pl
42 # TODO
43
44 %prep
45 %setup -q -n %{pdir}-%{pnam}-%{version}
46
47 %build
48 %{__perl} Build.PL \
49         installdirs=vendor \
50         destdir=$RPM_BUILD_ROOT
51 ./Build
52
53 %{?with_tests:./Build test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 ./Build install
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc AUTHORS BUGS Changes README TODO *.rdf
66 %attr(755,root,root) %{_bindir}/*
67 %{perl_vendorlib}/SQL/*.pm
68 %{perl_vendorlib}/SQL/Translator
69 %{perl_vendorlib}/Test/SQL/*.pm
70 %{_mandir}/man?/*
This page took 0.041216 seconds and 2 git commands to generate.