]> git.pld-linux.org Git - packages/perl-SDL.git/blob - perl-SDL.spec
- BR: perl-ExtUtils-CBuilder
[packages/perl-SDL.git] / perl-SDL.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        Simple DirectMedia Layer Perl
7 Summary(pl.UTF-8):      Interfejs Simple DirectMedia Layer dla Perla
8 Name:           perl-SDL
9 Version:        2.1.3
10 Release:        0.1
11 License:        LGPL
12 Group:          Development/Languages/Perl
13 Source0:        http://www.cpan.org/modules/by-authors/id/D/DG/DGOEHRIG/SDL_Perl-%{version}.tar.gz
14 # Source0-md5:  6ce26e1b710ce52def4ec22637cd5176
15 URL:            http://search.cpan.org/dist/SDL_Perl/
16 BuildRequires:  OpenGL-GLU-devel
17 BuildRequires:  SDL-devel
18 BuildRequires:  SDL_gfx-devel >= 2.0.10
19 BuildRequires:  SDL_image-devel
20 BuildRequires:  SDL_mixer-devel
21 BuildRequires:  SDL_net-devel
22 BuildRequires:  SDL_ttf-devel
23 BuildRequires:  libjpeg-devel
24 BuildRequires:  libpng-devel
25 BuildRequires:  perl-ExtUtils-CBuilder
26 BuildRequires:  perl-Module-Build
27 BuildRequires:  perl-Test-Simple
28 BuildRequires:  perl-YAML
29 BuildRequires:  perl-devel >= 1:5.8.0
30 BuildRequires:  rpm-perlprov >= 4.1-13
31 BuildRequires:  smpeg-devel
32 Provides:       perl(SDL::OpenGL)
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 SDL_perl is a package of perl modules that provides both functional
37 and object orient interfaces to the Simple DirectMedia Layer for Perl
38 5. This package does take some liberties with the SDL API, and
39 attempts to adhere to the spirit of both the SDL and Perl.
40
41 %description -l pl.UTF-8
42 SDL_perl to pakiet z modułami Perla udostępniający z poziomu Perla
43 interfejsy zarówno funkcjonalne, jak i zorientowane obiektowo do
44 biblioteki SDL (Simple DirectMedia Layer). Pakiet przejmuje trochę
45 swobody z API SDL i próbuje się dopasować do idei SDL oraz Perla.
46
47 %prep
48 %setup -q -n SDL_Perl-%{version}
49 mv t/mixerpm.t{,.blah}  # requires audio device
50
51 %build
52 %{__perl} Build.PL \
53         installdirs=vendor \
54         perl=%{__perl} \
55         destdir=$RPM_BUILD_ROOT \
56         config='optimize=%{rpmcflags}' \
57         config='lddlflags=-shared %{rpmldflags}'
58 ./Build
59
60 %{?with_tests:./Build test}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 ./Build install
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc BUGS CHANGELOG TODO README
73 %{_mandir}/man3/*
74 %{perl_vendorarch}/SDL*.pm
75 %{perl_vendorarch}/SDL
76 %dir %{perl_vendorarch}/auto/SDL
77 %dir %{perl_vendorarch}/auto/SDL_perl
78 %{perl_vendorarch}/auto/SDL_perl/SDL_perl.bs
79 %attr(755,root,root) %{perl_vendorarch}/auto/SDL_perl/SDL_perl.so
80 %dir %{perl_vendorarch}/auto/SDL/OpenGL
81 %{perl_vendorarch}/auto/SDL/OpenGL/OpenGL.bs
82 %attr(755,root,root)%{perl_vendorarch}/auto/SDL/OpenGL/OpenGL.so
83 %dir %{perl_vendorarch}/auto/SDL/SFont
84 %{perl_vendorarch}/auto/SDL/SFont/SFont.bs
85 %attr(755,root,root)%{perl_vendorarch}/auto/SDL/SFont/SFont.so
This page took 0.038336 seconds and 4 git commands to generate.