]> git.pld-linux.org Git - packages/perl-SDL.git/blob - perl-SDL.spec
- removed outdated detection patch
[packages/perl-SDL.git] / perl-SDL.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        Simple DirectMedia Layer Perl
7 Summary(pl):    Interfejs Simple DirectMedia Layer dla Perla
8 Name:           perl-SDL
9 Version:        2.1.3
10 Release:        0.1
11 License:        LGPL
12 Group:          Development/Languages/Perl
13 Source0:        http://www.cpan.org/modules/by-authors/id/D/DG/DGOEHRIG/SDL_Perl-%{version}.tar.gz
14 # Source0-md5:  6ce26e1b710ce52def4ec22637cd5176
15 URL:            http://search.cpan.org/dist/SDL_Perl/
16 BuildRequires:  OpenGL-GLU-devel
17 BuildRequires:  SDL-devel
18 BuildRequires:  SDL_gfx-devel >= 2.0.10
19 BuildRequires:  SDL_image-devel
20 BuildRequires:  SDL_mixer-devel
21 BuildRequires:  SDL_net-devel
22 BuildRequires:  SDL_ttf-devel
23 BuildRequires:  libjpeg-devel
24 BuildRequires:  libpng-devel
25 BuildRequires:  perl-Module-Build
26 BuildRequires:  perl-Test-Simple
27 BuildRequires:  perl-YAML
28 BuildRequires:  perl-devel >= 1:5.8.0
29 BuildRequires:  rpm-perlprov >= 4.1-13
30 BuildRequires:  smpeg-devel
31 Provides:       perl(SDL::OpenGL)
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 SDL_perl is a package of perl modules that provides both functional
36 and object orient interfaces to the Simple DirectMedia Layer for Perl
37 5. This package does take some liberties with the SDL API, and
38 attempts to adhere to the spirit of both the SDL and Perl.
39
40 %description -l pl
41 SDL_perl to pakiet z modu³ami Perla udostêpniaj±cy z poziomu Perla
42 interfejsy zarówno funkcjonalne, jak i zorientowane obiektowo do
43 biblioteki SDL (Simple DirectMedia Layer). Pakiet przejmuje trochê
44 swobody z API SDL i próbuje siê dopasowaæ do idei SDL oraz Perla.
45
46 %prep
47 %setup -q -n SDL_Perl-%{version}
48 mv t/mixerpm.t{,.blah}  # requires audio device
49
50 %build
51 %{__perl} Build.PL \
52         installdirs=vendor \
53         perl=%{__perl} \
54         destdir=$RPM_BUILD_ROOT \
55         config='optimize=%{rpmcflags}' \
56         config='lddlflags=-shared %{rpmldflags}'
57 ./Build
58
59 %{?with_tests:./Build test}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 ./Build install
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc BUGS CHANGELOG TODO README
72 %{_mandir}/man3/*
73 %{perl_vendorarch}/SDL*.pm
74 %{perl_vendorarch}/SDL
75 %dir %{perl_vendorarch}/auto/SDL
76 %dir %{perl_vendorarch}/auto/SDL_perl
77 %{perl_vendorarch}/auto/SDL_perl/SDL_perl.bs
78 %attr(755,root,root) %{perl_vendorarch}/auto/SDL_perl/SDL_perl.so
79 %dir %{perl_vendorarch}/auto/SDL/OpenGL
80 %{perl_vendorarch}/auto/SDL/OpenGL/OpenGL.bs
81 %attr(755,root,root)%{perl_vendorarch}/auto/SDL/OpenGL/OpenGL.so
82 %dir %{perl_vendorarch}/auto/SDL/SFont
83 %{perl_vendorarch}/auto/SDL/SFont/SFont.bs
84 %attr(755,root,root)%{perl_vendorarch}/auto/SDL/SFont/SFont.so
This page took 0.036201 seconds and 4 git commands to generate.