]> git.pld-linux.org Git - packages/perl-SDL.git/blob - perl-SDL.spec
- proper Module::Build usage (with optflags support)
[packages/perl-SDL.git] / perl-SDL.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        Simple DirectMedia Layer Perl
7 Summary(pl):    Interfejs Simple DirectMedia Layer dla Perla
8 Name:           perl-SDL
9 Version:        2.1.0
10 Release:        1
11 License:        LGPL
12 Group:          Development/Languages/Perl
13 Source0:        http://search.cpan.org/CPAN/authors/id/D/DG/DGOEHRIG/SDL_Perl-%{version}.tar.gz
14 # Source0-md5:  7dc4ab6620003f37ff4093d052ed46fa
15 Patch0:         %{name}-detection.patch
16 URL:            http://search.cpan.org/dist/SDL_Perl/
17 BuildRequires:  OpenGL-devel
18 BuildRequires:  SDL-devel
19 BuildRequires:  SDL_gfx-devel >= 2.0.10
20 BuildRequires:  SDL_image-devel
21 BuildRequires:  SDL_mixer-devel
22 BuildRequires:  SDL_net-devel
23 BuildRequires:  SDL_ttf-devel
24 BuildRequires:  glut-devel
25 BuildRequires:  libjpeg-devel
26 BuildRequires:  libpng-devel
27 BuildRequires:  perl-Module-Build
28 BuildRequires:  perl-Test-Simple
29 BuildRequires:  perl-devel >= 1:5.8.0
30 BuildRequires:  rpm-perlprov >= 4.1-13
31 BuildRequires:  smpeg-devel
32 Provides:       perl(SDL::OpenGL)
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 SDL_perl is a package of perl modules that provides both functional
37 and object orient interfaces to the Simple DirectMedia Layer for Perl
38 5. This package does take some liberties with the SDL API, and
39 attempts to adhere to the spirit of both the SDL and Perl.
40
41 %description -l pl
42 SDL_perl to pakiet z modu³ami perla udostêpniaj±cy z poziomu Perla
43 interfejsy zarówno funkcjonalne, jak i zorientowane obiektowo do
44 biblioteki SDL (Simple DirectMedia Layer). Pakiet przejmuje trochê
45 swobody z API SDL i próbuje siê dopasowaæ do idei SDL oraz Perla.
46
47 %prep
48 %setup -q -n SDL_Perl-%{version}
49 #%patch0 -p1
50
51 %build
52 %{__perl} Build.PL \
53         installdirs=vendor \
54         perl=%{__perl} \
55         destdir=$RPM_BUILD_ROOT \
56         config='optflags=%{rpmcflags}'
57 ./Build
58
59 %{?with_tests:./Build test}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 ./Build install
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc BUGS CHANGELOG TODO README
72 %{_mandir}/man3/*
73 %{perl_vendorarch}/SDL*.pm
74 %{perl_vendorarch}/SDL
75 %dir %{perl_vendorarch}/auto/SDL
76 %dir %{perl_vendorarch}/auto/SDL_perl
77 %{perl_vendorarch}/auto/SDL_perl/SDL_perl.bs
78 %attr(755,root,root) %{perl_vendorarch}/auto/SDL_perl/SDL_perl.so
79 %dir %{perl_vendorarch}/auto/SDL/OpenGL
80 %{perl_vendorarch}/auto/SDL/OpenGL/OpenGL.bs
81 %attr(755,root,root)%{perl_vendorarch}/auto/SDL/OpenGL/OpenGL.so
82 %dir %{perl_vendorarch}/auto/SDL/SFont
83 %{perl_vendorarch}/auto/SDL/SFont/SFont.bs
84 %attr(755,root,root)%{perl_vendorarch}/auto/SDL/SFont/SFont.so
This page took 0.035842 seconds and 4 git commands to generate.