]> git.pld-linux.org Git - packages/perl-SDL.git/blob - perl-SDL.spec
- rebuild with SDL_gfx 2.0.26
[packages/perl-SDL.git] / perl-SDL.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        Simple DirectMedia Layer Perl
7 Summary(pl.UTF-8):      Interfejs Simple DirectMedia Layer dla Perla
8 Name:           perl-SDL
9 Version:        2.1.3
10 Release:        14
11 License:        LGPL
12 Group:          Development/Languages/Perl
13 Source0:        http://www.cpan.org/modules/by-authors/id/D/DG/DGOEHRIG/SDL_Perl-%{version}.tar.gz
14 # Source0-md5:  6ce26e1b710ce52def4ec22637cd5176
15 Patch0:         %{name}-gfxPie.patch
16 Patch1:         %{name}-no-mixertest.patch
17 URL:            http://search.cpan.org/dist/SDL_Perl/
18 BuildRequires:  OpenGL-GLU-devel
19 BuildRequires:  SDL-devel
20 BuildRequires:  SDL_gfx-devel >= 2.0.10
21 BuildRequires:  SDL_image-devel
22 BuildRequires:  SDL_mixer-devel
23 BuildRequires:  SDL_net-devel
24 BuildRequires:  SDL_ttf-devel
25 BuildRequires:  libjpeg-devel
26 BuildRequires:  libpng-devel
27 BuildRequires:  perl-ExtUtils-CBuilder
28 BuildRequires:  perl-Module-Build
29 BuildRequires:  perl-Test-Simple
30 BuildRequires:  perl-YAML
31 BuildRequires:  perl-devel >= 1:5.8.0
32 BuildRequires:  rpm-perlprov >= 4.1-13
33 BuildRequires:  smpeg-devel
34 Provides:       perl(SDL::OpenGL)
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 SDL_perl is a package of perl modules that provides both functional
39 and object orient interfaces to the Simple DirectMedia Layer for Perl
40 5. This package does take some liberties with the SDL API, and
41 attempts to adhere to the spirit of both the SDL and Perl.
42
43 %description -l pl.UTF-8
44 SDL_perl to pakiet z modułami Perla udostępniający z poziomu Perla
45 interfejsy zarówno funkcjonalne, jak i zorientowane obiektowo do
46 biblioteki SDL (Simple DirectMedia Layer). Pakiet przejmuje trochę
47 swobody z API SDL i próbuje się dopasować do idei SDL oraz Perla.
48
49 %prep
50 %setup -q -n SDL_Perl-%{version}
51 %patch0 -p0
52 %patch1 -p1
53
54 mv t/mixerpm.t{,.blah}  # requires audio device
55
56 %build
57 %{__perl} Build.PL \
58         installdirs=vendor \
59         perl=%{__perl} \
60         destdir=$RPM_BUILD_ROOT \
61         config='optimize=%{rpmcflags}' \
62         config='lddlflags=-shared %{rpmldflags}'
63 ./Build
64
65 # <sigh> I don't know why but for some reason these dirs get put under
66 # blib/arch/auto/src instead of blib/arch/auto causing them to be installed
67 # in the wrong location and "./Build test" to fail. We copy them because if
68 # we move them the next call to ./Build will recreate them in the wrong
69 # location anyways. Unfortunatly with the copy the wrong located originals
70 # will also end up getting installed so we must remove those in %%install
71 cp -r blib/arch/auto/src/SDL* blib/arch/auto
72
73 %{?with_tests:./Build test}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77
78 ./Build install
79 rm -rf $RPM_BUILD_ROOT%{perl_vendorarch}/auto/src
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %files
85 %defattr(644,root,root,755)
86 %doc BUGS CHANGELOG TODO README
87 %{_mandir}/man3/*
88 %{perl_vendorarch}/SDL*.pm
89 %{perl_vendorarch}/SDL
90 %dir %{perl_vendorarch}/auto/SDL
91 %dir %{perl_vendorarch}/auto/SDL_perl
92 %attr(755,root,root) %{perl_vendorarch}/auto/SDL_perl/SDL_perl.so
93 %dir %{perl_vendorarch}/auto/SDL/OpenGL
94 %attr(755,root,root)%{perl_vendorarch}/auto/SDL/OpenGL/OpenGL.so
95 %dir %{perl_vendorarch}/auto/SDL/SFont
96 %attr(755,root,root)%{perl_vendorarch}/auto/SDL/SFont/SFont.so
This page took 0.085688 seconds and 3 git commands to generate.