]> git.pld-linux.org Git - packages/perl-Regexp-Assemble.git/blob - perl-Regexp-Assemble.spec
48a5860e80aecd3cec23add34c16b509b0d75120
[packages/perl-Regexp-Assemble.git] / perl-Regexp-Assemble.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Regexp
7 %define pnam    Assemble
8 Summary:        Regexp::Assemble - Assemble multiple Regular Expressions into a single RE
9 #Summary(pl.UTF-8):     
10 Name:           perl-Regexp-Assemble
11 Version:        0.35
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Regexp/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  315796ece5bfb69b166846ced911cf0e
18 URL:            http://search.cpan.org/dist/Regexp-Assemble/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Regexp::Assemble takes an arbitrary number of regular expressions
26 and assembles them into a single regular expression (or RE) that
27 matches all that the individual REs match.
28
29 # %description -l pl.UTF-8
30 # TODO
31
32 %prep
33 %setup -q -n %{pdir}-%{pnam}-%{version}
34
35 %build
36 %{__perl} Makefile.PL \
37         INSTALLDIRS=vendor
38 %{__make}
39
40 %{?with_tests:%{__make} test}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 %{__make} pure_install \
46         DESTDIR=$RPM_BUILD_ROOT
47
48 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
49 cp -a eg $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes TODO
57 %{perl_vendorlib}/Regexp/*.pm
58 %{_mandir}/man3/*
59 %{_examplesdir}/%{name}-%{version}
This page took 0.067795 seconds and 2 git commands to generate.