]> git.pld-linux.org Git - packages/perl-RPM.git/blob - perl-RPM.spec
- removed zero-sized .bs file
[packages/perl-RPM.git] / perl-RPM.spec
1 #
2 %bcond_with     tests   # perform "make test" (uses rpm database, which must not
3                         # be broken by gettext-in-header patch)
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        Native bindings to the RPM Package Manager API for Perl
7 Summary(pl.UTF-8):      Natywne dowiązania do API zarządcy pakietów RPM dla Perla
8 Name:           perl-RPM
9 Version:        0.40
10 Release:        11
11 License:        Artistic
12 Group:          Development/Languages/Perl
13 Source0:        http://www.cpan.org/modules/by-module/RPM/Perl-RPM-%{version}.tar.gz
14 # Source0-md5:  f15aa29bd0af0e1102d757ce20500f26
15 Patch0:         %{name}-43.patch
16 Patch1:         %{name}-45.patch
17 URL:            http://www.blackperl.com/Perl-RPM/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-devel >= 4.4.1
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22 Obsoletes:      Perl-RPM
23
24 %description
25 The Perl-RPM package is an attempt to provide Perl-level access to the
26 complete application programming interface that is a part of the RPM
27 Package Manager (RPM). Rather than have scripts rely on executing RPM
28 commands and parse the resultant output, this modules aims to provide
29 Perl programmers the ability to do anything that would otherwise have
30 been done in C or C++.
31
32 %description -l pl.UTF-8
33 Pakiet Perl-RPM to próba dostarczenia dostępu z poziomu Perla do
34 pełnego interfejsu programistycznego, będącego częścią zarządcy
35 pakietów RPM. Zamiast polegać na wywoływaniu poleceń RPM i
36 analizowaniu ich wyjścia, te moduły próbują dostarczyć programistom
37 perlowym możliwość robienia wszystkiego, co musiałoby być robione w C
38 lub C++.
39
40 %prep
41 %setup -q -n Perl-RPM-%{version}
42 %patch0 -p1
43 %patch1 -p1
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48 %{__make} \
49         CC="%{__cc}" \
50         OPTIMIZE="%{rpmcflags}"
51
52 %{?with_tests:%{__make} test}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc README
66 %attr(755,root,root) %{_bindir}/rpmprune
67 %{perl_vendorarch}/RPM.pm
68 %{perl_vendorarch}/RPM
69 %dir %{perl_vendorarch}/auto/RPM
70 %attr(755,root,root) %{perl_vendorarch}/auto/RPM/*.so
71 %{_mandir}/man[13]/*
This page took 0.061688 seconds and 3 git commands to generate.