]> git.pld-linux.org Git - packages/perl-Quantum-Superpositions.git/blob - perl-Quantum-Superpositions.spec
use generic url
[packages/perl-Quantum-Superpositions.git] / perl-Quantum-Superpositions.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Quantum
6 %define         pnam    Superpositions
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Quantum::Superpositions - QM-like superpositions in Perl
9 Summary(pl.UTF-8):      Quantum::Superpositions - superpozycje z mechaniki kwantowej w Perlu
10 Name:           perl-Quantum-Superpositions
11 Version:        2.02
12 Release:        2
13 # same as perl (5.6.1 or later)
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  40a3a398ca24be6de510667d92c02f5e
18 URL:            http://search.cpan.org/dist/Quantum-Superpositions/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Class-Multimethods
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Quantum::Superpositions provides a new scalar data structure: the
29 superposition. In a metaphor drawn from quantum mechanics,
30 superpositions store a collection of values by overlaying them in
31 parallel superimposed states within a single scalar variable.
32
33 The Quantum::Superpositions module adds two new operators to Perl: any
34 and all.
35
36 %description -l pl.UTF-8
37 Moduł Quantum::Superpositions udostępnia nową strukturę danych
38 skalarnych: superpozycję. Jest to metafora pochodząca z mechaniki
39 kwantowej - superpozycje przechowują zestaw zmiennych poprzez
40 nakładanie ich w równolegle złożonych stanach w pojedynczej zmiennej
41 skalarnej.
42
43 Moduł Quantum::Superpositions dodaje dwa nowe operatory do Perla: any
44 i all.
45
46 %prep
47 %setup -q -n %{pdir}-%{pnam}-%{version}
48
49 %build
50 %{__perl} Makefile.PL \
51         INSTALLDIRS=vendor
52 %{__make}
53
54 %{?with_tests:%{__make} test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc Change*
68 %{perl_vendorlib}/%{pdir}/*.pm
69 %{_mandir}/man3/*
This page took 0.063124 seconds and 3 git commands to generate.