]> git.pld-linux.org Git - packages/perl-Qt.git/blob - perl-Qt.spec
- release 13 (by relup.sh)
[packages/perl-Qt.git] / perl-Qt.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    PerlQt
7 Summary:        Qt - A Perl module interface to Qt
8 Summary(pl.UTF-8):      Qt - interfejs Perla do Qt
9 Name:           perl-Qt
10 Version:        3.008
11 Release:        13
12 License:        GPL
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Qt/%{pdir}-%{version}.tar.gz
15 # Source0-md5:  a0cdc0c86b3e79c56f09f2af8c4c2c39
16 Patch0:         format-security.patch
17 URL:            http://search.cpan.org/dist/Qt/
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  qt-devel
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRequires:  xorg-lib-libXext-devel
23 BuildRequires:  xorg-lib-libXi-devel
24 BuildRequires:  xorg-lib-libXt-devel
25 BuildRequires:  zlib-devel
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 The Qt module itself only creates a $qApp and exports some QGlobal
30 imports.
31
32 This module is not the whole of the Qt interface, though. Each header
33 in Qt which holds a class is represented by a module with the name of
34 that class. Classes like QWidget and QApplication are represented by
35 modules of the same name. QResizeEvent is not a module, but rather is
36 part of the QEvent module, just as the QResizeEvent class is a part of
37 qevent.h.
38
39 Each class header that has been interfaced to Perl has a pod attached
40 which describes the function interface from Qt.
41
42 %description -l pl.UTF-8
43 Interfejs Perla do Qt.
44
45 %prep
46 %setup -q -n %{pdir}-%{version}
47 %patch0 -p1
48
49 %{__sed} 's/ -Wmissing-prototypes / /' -i configure
50
51 %build
52 %{__perl} Makefile.PL \
53         --prefix=%{_prefix} \
54         --with-qt-dir=%{_libdir} \
55         INSTALLDIRS=vendor
56
57 %configure
58
59 cd PerlQt
60 %{__perl} Makefile.PL \
61         INSTALLDIRS=vendor
62 cd ..
63
64 %{__make}
65
66 %{?with_tests:%{__make} test}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %{__make} install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %post -p /sbin/ldconfig
78 %postun -p /sbin/ldconfig
79
80 %files
81 %defattr(644,root,root,755)
82 %doc INSTALL README TODO
83 %attr(755,root,root) %{_bindir}/pqtapi
84 %attr(755,root,root) %{_bindir}/pqtsh
85 %attr(755,root,root) %{_bindir}/puic
86 %{perl_vendorarch}/Qt.pm
87 %dir %{perl_vendorarch}/Qt
88 %{perl_vendorarch}/Qt/*.pm
89 %dir %{perl_vendorarch}/auto/Qt
90 %attr(755,root,root) %{perl_vendorarch}/auto/Qt/*.so
91 %{_mandir}/man1/puic.1*
92 %{_mandir}/man3/Qt.3*
93 %attr(755,root,root) %{_libdir}/libsmokeqt.so.*.*.*
94 %ghost %attr(755,root,root) %{_libdir}/libsmokeqt.so.1
This page took 0.114782 seconds and 3 git commands to generate.