]> git.pld-linux.org Git - packages/perl-Python-Bytecode.git/blob - perl-Python-Bytecode.spec
c5f7d453a155b735204e2708e394768bcedd7b27
[packages/perl-Python-Bytecode.git] / perl-Python-Bytecode.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Python
7 %define pnam    Bytecode
8 Summary:        Python::Bytecode - Disassemble and investigate Python bytecode
9 Name:           perl-Python-Bytecode
10 Version:        2.7
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Python/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  e357351a3bf32c54ac1aa8910b4c53f7
17 URL:            http://search.cpan.org/dist/Python-Bytecode/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Python::Bytecode accepts a string or filehandle contain Python
25 bytecode and puts it into a format you can manipulate.
26
27 %prep
28 %setup -q -n %{pdir}-%{pnam}-%{version}
29
30 %build
31 %{__perl} Makefile.PL \
32         INSTALLDIRS=vendor
33 %{__make}
34
35 %{?with_tests:%{__make} test}
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39
40 %{__make} pure_install \
41         DESTDIR=$RPM_BUILD_ROOT
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %files
47 %defattr(644,root,root,755)
48 %doc Changes README
49 %{perl_vendorlib}/Python/*.pm
50 %{perl_vendorlib}/Python/Bytecode
51 %{_mandir}/man3/*
This page took 0.085414 seconds and 2 git commands to generate.