]> git.pld-linux.org Git - packages/perl-Python-Bytecode.git/blob - perl-Python-Bytecode.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Python-Bytecode.git] / perl-Python-Bytecode.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Python
6 %define pnam    Bytecode
7 Summary:        Python::Bytecode - Disassemble and investigate Python bytecode
8 Name:           perl-Python-Bytecode
9 Version:        2.7
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Python/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  e357351a3bf32c54ac1aa8910b4c53f7
16 URL:            http://search.cpan.org/dist/Python-Bytecode/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Python::Bytecode accepts a string or filehandle contain Python
24 bytecode and puts it into a format you can manipulate.
25
26 %prep
27 %setup -q -n %{pdir}-%{pnam}-%{version}
28
29 %build
30 %{__perl} Makefile.PL \
31         INSTALLDIRS=vendor
32 %{__make}
33
34 %{?with_tests:%{__make} test}
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38
39 %{__make} pure_install \
40         DESTDIR=$RPM_BUILD_ROOT
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %files
46 %defattr(644,root,root,755)
47 %doc Changes README
48 %{perl_vendorlib}/Python/*.pm
49 %{perl_vendorlib}/Python/Bytecode
50 %{_mandir}/man3/*
This page took 0.040518 seconds and 3 git commands to generate.