]> git.pld-linux.org Git - packages/perl-Proc-Wait3.git/blob - perl-Proc-Wait3.spec
aa07506f3fa7c66f6bbd36622601cddf6988f216
[packages/perl-Proc-Wait3.git] / perl-Proc-Wait3.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Proc
6 %define         pnam    Wait3
7 Summary:        Proc::Wait3 - Perl extension for wait3 system call
8 Name:           perl-Proc-Wait3
9 Version:        0.05
10 Release:        2
11 License:        unknown
12 Group:          Development/Languages/Perl
13 Source0:        http://www.cpan.org/modules/by-module/Proc/%{pdir}-%{pnam}-%{version}.tar.gz
14 # Source0-md5:  41e6db9547b3f2c858d1982f6c278a1b
15 URL:            http://search.cpan.org/dist/Proc-Wait3/
16 BuildRequires:  perl-devel >= 1:5.8.0
17 BuildRequires:  rpm-perlprov >= 4.1-13
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 If any child processes have exited, this call will "reap" the zombies
22 similar to the perl "wait" function.
23
24 By default, it will return immediately and if there are no dead
25 children, everything will be undefined.  If you pass in a true
26 argument, it will block until a child exits (or it gets a signal).
27
28  $pid         PID of exiting child
29
30  $status      exit status of child, just like C<$?>
31
32  $utime       floating point user cpu seconds
33
34  $stime       floating point system cpu seconds
35
36  $maxrss      the maximum resident set size utilized (in kilobytes).
37
38  $minflt      the number of page faults serviced without any I/O
39               activity; here I/O activity is avoided by "reclaiming" a
40               page frame from the list of pages awaiting reallocation.
41
42  $majflt      the number of page faults serviced that required I/O
43               activity.
44
45  $nswap       the number of times a process was "swapped" out of main
46               memory.
47
48  $inblock     the number of times the file system had to perform input.
49
50  $oublock     the number of times the file system had to perform output.
51
52  $msgsnd      the number of messages sent over sockets.
53
54  $msgrcv      the number of messages received from sockets.
55
56  $nsignals    the number of signals delivered.
57
58  $nvcsw       the number of times a context switch resulted due to a
59               process voluntarily giving up the processor before its
60               time slice was completed (usually to await availability of
61               a resource).
62
63  $nivcsw      the number of times a context switch resulted due to a
64               higher priority process becoming runnable or because the
65               current process exceeded its time slice.
66
67
68
69 # %description -l pl.UTF-8
70 # TODO
71
72 %prep
73 %setup -q -n %{pdir}-%{pnam}-%{version}
74
75 %build
76 %{__perl} Makefile.PL \
77         INSTALLDIRS=vendor
78 %{__make} \
79         CC="%{__cc}" \
80         OPTIMIZE="%{rpmcflags}"
81
82 %{?with_tests:%{__make} test}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86
87 %{__make} pure_install \
88         DESTDIR=$RPM_BUILD_ROOT
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %files
94 %defattr(644,root,root,755)
95 %doc Changes README
96 %{perl_vendorarch}/Proc/*.pm
97 %dir %{perl_vendorarch}/auto/Proc/Wait3
98 %attr(755,root,root) %{perl_vendorarch}/auto/Proc/Wait3/*.so
99 %{_mandir}/man3/*
This page took 0.052616 seconds and 2 git commands to generate.