]> git.pld-linux.org Git - packages/perl-Proc-Wait3.git/blob - perl-Proc-Wait3.spec
49544f7b50c22ae8df555ca7e82b58305c96df39
[packages/perl-Proc-Wait3.git] / perl-Proc-Wait3.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Proc
6 %define         pnam    Wait3
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Proc::Wait3 - Perl extension for wait3 system call
9 #Summary(pl.UTF-8):     
10 Name:           perl-Proc-Wait3
11 Version:        0.04
12 Release:        5
13 License:        unknown
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Proc/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  d87ce5f3557eb86bfa5bafb9f2e028e3
17 # generic URL, check or change before uncommenting
18 #URL:           http://search.cpan.org/dist/Proc-Wait3/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 %endif
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 If any child processes have exited, this call will "reap" the zombies
27 similar to the perl "wait" function.
28
29 By default, it will return immediately and if there are no dead
30 children, everything will be undefined.  If you pass in a true
31 argument, it will block until a child exits (or it gets a signal).
32
33  $pid         PID of exiting child
34
35  $status      exit status of child, just like C<$?>
36
37  $utime       floating point user cpu seconds
38
39  $stime       floating point system cpu seconds
40
41  $maxrss      the maximum resident set size utilized (in kilobytes).
42
43  $minflt      the number of page faults serviced without any I/O
44               activity; here I/O activity is avoided by "reclaiming" a
45               page frame from the list of pages awaiting reallocation.
46
47  $majflt      the number of page faults serviced that required I/O
48               activity.
49
50  $nswap       the number of times a process was "swapped" out of main
51               memory.
52
53  $inblock     the number of times the file system had to perform input.
54
55  $oublock     the number of times the file system had to perform output.
56
57  $msgsnd      the number of messages sent over sockets.
58
59  $msgrcv      the number of messages received from sockets.
60
61  $nsignals    the number of signals delivered.
62
63  $nvcsw       the number of times a context switch resulted due to a
64               process voluntarily giving up the processor before its
65               time slice was completed (usually to await availability of
66               a resource).
67
68  $nivcsw      the number of times a context switch resulted due to a
69               higher priority process becoming runnable or because the
70               current process exceeded its time slice.
71
72
73
74 # %description -l pl.UTF-8
75 # TODO
76
77 %prep
78 %setup -q -n %{pdir}-%{pnam}-%{version}
79
80 %build
81 %{__perl} Makefile.PL \
82         INSTALLDIRS=vendor
83 %{__make} \
84         CC="%{__cc}" \
85         OPTIMIZE="%{rpmcflags}"
86
87 %{?with_tests:%{__make} test}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91
92 %{__make} pure_install \
93         DESTDIR=$RPM_BUILD_ROOT
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %files
99 %defattr(644,root,root,755)
100 %doc Changes README
101 %{perl_vendorarch}/Proc/*.pm
102 %dir %{perl_vendorarch}/auto/Proc/Wait3
103 %attr(755,root,root) %{perl_vendorarch}/auto/Proc/Wait3/*.so
104 %{_mandir}/man3/*
This page took 0.059168 seconds and 2 git commands to generate.