]> git.pld-linux.org Git - packages/perl-Proc-ProcessTable.git/blob - perl-Proc-ProcessTable.spec
- rebuild with perl 5.30.0
[packages/perl-Proc-ProcessTable.git] / perl-Proc-ProcessTable.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # do perform "make test" (requires mounted /proc)
4
5 %define         pdir    Proc
6 %define         pnam    ProcessTable
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Proc::ProcessTable - Perl interface to the UNIX process table
9 Summary(pl.UTF-8):      Proc::ProcessTable - interfejs perlowy do uniksowej tabeli procesów
10 Name:           perl-Proc-ProcessTable
11 Version:        0.59
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Proc/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  3330a3648eeaad54d19a091742a2ac5a
18 URL:            http://search.cpan.org/dist/Proc-ProcessTable/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This module is a first crack at providing a consistent interface to
25 Unix (and maybe other multitasking OS's) process table information.
26 The impetus for this came about with my frustration at having to parse
27 the output of various systems' ps commands to check whether specific
28 processes were running on different boxes at a larged mixed UNIX site.
29 The output format of ps was different on each OS, and sometimes
30 changed with each new release of an OS. Also, running a ps subprocess
31 from within a perl or shell script and parsing the output was not a
32 very efficient or aesthetic way to do things.
33
34 %description -l pl.UTF-8
35 Ten moduł to pierwsza próba udostępnienia spójnego interfejsu do
36 informacji dotyczących uniksowej (i może z innych wielozadaniowych
37 systemów operacyjnych) tabeli procesów. Impuls do stworzenia tego
38 pojawił się wraz z frustracją autora przy analizie wyjścia poleceń ps
39 z różnych systemów w celu sprawdzenia, czy określone procesy działają
40 na różnych maszynach w dużym zestawie różnych Uniksów. Format wyjścia
41 ps był różny na każdym systemie, a czasem zmieniał się wraz z nową
42 wersją systemu. Poza tym uruchamianie procesu ps z Perla lub skryptu
43 powłoki i analiza jego wyjścia nie były zbyt wydajnym ani estetycznym
44 sposobem.
45
46 %prep
47 %setup -q -n %{pdir}-%{pnam}-%{version}
48
49 %build
50 %{__perl} Makefile.PL \
51         INSTALLDIRS=vendor
52 %{__make} \
53         CC="%{__cc}" \
54         OPTIMIZE="%{rpmcflags}"
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc README README.linux Changes
69 %dir %{perl_vendorarch}/Proc
70 %{perl_vendorarch}/Proc/*.pm
71 %{perl_vendorarch}/Proc/ProcessTable
72 %dir %{perl_vendorarch}/auto/Proc
73 %dir %{perl_vendorarch}/auto/Proc/ProcessTable
74 %attr(755,root,root) %{perl_vendorarch}/auto/Proc/ProcessTable/*.so
75 %{perl_vendorarch}/auto/Proc/ProcessTable/Process
76 %{_mandir}/man3/Proc::Killall.3pm*
77 %{_mandir}/man3/Proc::Killfam.3pm*
78 %{_mandir}/man3/Proc::ProcessTable*
This page took 0.030492 seconds and 3 git commands to generate.