]> git.pld-linux.org Git - packages/perl-Proc-InvokeEditor.git/blob - perl-Proc-InvokeEditor.spec
- up to 1.13
[packages/perl-Proc-InvokeEditor.git] / perl-Proc-InvokeEditor.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Proc
6 %define         pnam    InvokeEditor
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Proc::InvokeEditor - Perl extension for starting a text editor
9 Name:           perl-Proc-InvokeEditor
10 Version:        1.13
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Proc/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  26595c1e1c80ed64f0fb97cceea7e167
17 URL:            http://search.cpan.org/dist/Proc-InvokeEditor/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(Carp::Assert) >= 0.11
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This module provides the ability to supply some text to an external
28 text editor, have it edited by the user, and retrieve the results.
29
30 The File::Temp module is used to provide secure, safe temporary
31 files, and File::Temp is set to its highest available level of
32 security. This may cause problems on some systems where no secure
33 temporary directory is available.
34
35 When the editor is started, no subshell is used. Your path will
36 be scanned to find the binary to use for each editor if the string
37 given does not exist as a file, and if a named editor contains whitespace,
38 eg) if you try to use the editor xemacs -nw, then the string will
39 be split on whitespace and anything after the editor name will be passed
40 as arguments to your editor. A shell is not used but this should cover
41 most simple cases.
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} pure_install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
60 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc Changes README
68 %{perl_vendorlib}/Proc/InvokeEditor.pm
69 %{_mandir}/man3/*
70 %{_examplesdir}/%{name}-%{version}
This page took 0.033176 seconds and 3 git commands to generate.