]> git.pld-linux.org Git - packages/perl-Pipeline.git/blob - perl-Pipeline.spec
f424826ece65cd4efddf7cc8132723e766320be9
[packages/perl-Pipeline.git] / perl-Pipeline.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Pipeline
7 Summary:        Pipeline - generic pipeline interface
8 Summary(pl.UTF-8):      Pipeline - interfejs do obsługi potoków
9 Name:           perl-%{pdir}
10 Version:        3.12
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/R/RC/RCLAMP/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  52cbc818aa18f7307dc00624741e5a73
17 URL:            http://search.cpan.org/dist/Pipeline/
18 BuildRequires:  perl-Class-ISA >= 0.01
19 BuildRequires:  perl-Data-Structure-Util >= 0.04
20 BuildRequires:  perl-Data-UUID >= 0.01
21 BuildRequires:  perl-Error >= 0.15
22 BuildRequires:  perl-IO-Null >= 0.01
23 BuildRequires:  perl-IO-String >= 0.01
24 BuildRequires:  perl-devel >= 1:5.8.0
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Pipelines are a mechanism to process data. They are designed to be
31 plugged together to make fairly complex operations act in a fairly
32 straightforward manner, cleanly, and simply.
33
34 %description -l pl.UTF-8
35 Moduł Perla Pipelines stanowi mechanizm do przetwarzania danych.
36 Został on zaprojektowany do włączania go w skomplikowane operacje,
37 żeby działały one w sposób łatwy, jasny i prosty.
38
39 %prep
40 %setup -q -n %{pdir}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc CHANGES README
62 %{perl_vendorlib}/Pipeline
63 %{perl_vendorlib}/Pipeline.pm
64 %{_mandir}/man3/*
This page took 0.05205 seconds and 2 git commands to generate.