]> git.pld-linux.org Git - packages/perl-Paw.git/blob - perl-Paw.spec
use generic url
[packages/perl-Paw.git] / perl-Paw.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pnam    Paw
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        Paw Perl module
8 Summary(cs.UTF-8):      Modul Paw pro Perl
9 Summary(da.UTF-8):      Perlmodul Paw
10 Summary(de.UTF-8):      Paw Perl Modul
11 Summary(es.UTF-8):      Módulo de Perl Paw
12 Summary(fr.UTF-8):      Module Perl Paw
13 Summary(it.UTF-8):      Modulo di Perl Paw
14 Summary(ja.UTF-8):      Paw Perl モジュール
15 Summary(ko.UTF-8):      Paw 펄 모줄
16 Summary(nb.UTF-8):      Perlmodul Paw
17 Summary(pl.UTF-8):      Moduł Perla Paw
18 Summary(pt.UTF-8):      Módulo de Perl Paw
19 Summary(pt_BR.UTF-8):   Módulo Perl Paw
20 Summary(ru.UTF-8):      Модуль для Perl Paw
21 Summary(sv.UTF-8):      Paw Perlmodul
22 Summary(uk.UTF-8):      Модуль для Perl Paw
23 Summary(zh_CN.UTF-8):   Paw Perl 模块
24 Name:           perl-Paw
25 Version:        0.54
26 Release:        2
27 License:        GPL
28 Group:          Development/Languages/Perl
29 Source0:        http://www.cpan.org/modules/by-authors/id/U/UG/UGANSERT/%{pnam}-%{version}.tar.gz
30 # Source0-md5:  1bdc9ec343614dc345f8c602f716f777
31 URL:            http://search.cpan.org/dist/Paw/
32 BuildRequires:  perl-Curses
33 BuildRequires:  perl-devel >= 1:5.8.0
34 BuildRequires:  rpm-perlprov >= 4.1-13
35 BuildArch:      noarch
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Perl Paw modules.
40
41 %description -l pl.UTF-8
42 Moduł Perla Paw.
43
44 %prep
45 %setup -q -n %{pnam}-%{version}
46
47 %build
48 %{__perl} Makefile.PL \
49         INSTALLDIRS=vendor
50 %{__make}
51
52 %{?with_tests:%{__make} test}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} \
57         $RPM_BUILD_ROOT%{_mandir}/{,de/}man3
58
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61 cp -f Paw/examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
62 rm -rf $RPM_BUILD_ROOT%{perl_vendorlib}/Paw/examples
63
64 cd $RPM_BUILD_ROOT%{perl_vendorlib}/Paw
65 mv Paw-de.pod Paw.pod
66 pod2man --section=3pm Paw.pod >$RPM_BUILD_ROOT%{_mandir}/de/man3/Paw.3pm
67 rm -f Paw.pod
68
69 for i in *-de.pod; do
70         n=`echo $i | sed 's/-de\.pod$//'`
71         mv $i $n.pod
72         pod2man --section=3pm $n.pod >$RPM_BUILD_ROOT%{_mandir}/de/man3/Paw::$n.3pm
73 done
74 rm -f *.pod
75
76 for i in *.pm; do
77         if grep '^=head' $i >/dev/null; then
78                 n=`echo $i | sed 's/\.pm$//'`
79                 pod2man --section=3pm $i >$RPM_BUILD_ROOT%{_mandir}/man3/Paw::$n.3pm
80         fi
81 done
82
83 cd ..
84 pod2man --section=3pm Paw.pm >$RPM_BUILD_ROOT%{_mandir}/man3/Paw.3pm
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %files
90 %defattr(644,root,root,755)
91 %doc Changes.txt
92 %dir %{perl_vendorlib}/Paw
93 %{perl_vendorlib}/Paw/*.pm
94 %{perl_vendorlib}/Paw.pm
95 %{_mandir}/man3/*
96 %lang(de) %{_mandir}/de/man3/*
97 %dir %{_examplesdir}/%{name}-%{version}
98 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*.pl
This page took 0.080197 seconds and 3 git commands to generate.