]> git.pld-linux.org Git - packages/perl-Passwd-Linux.git/blob - perl-Passwd-Linux.spec
rebuild with perl 5.32
[packages/perl-Passwd-Linux.git] / perl-Passwd-Linux.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # do not perform "make test"
4 #
5 %define pdir    Passwd
6 %define pnam    Linux
7 Summary:        Passwd::Linux - Perl module for manipulating the passwd and shadow files
8 Summary(pl.UTF-8):      Passwd::Linux - Moduł Perla do manipulowania plikami passwd i shadow
9 Name:           perl-Passwd-Linux
10 Version:        1.2
11 Release:        7
12 License:        unknown
13 Group:          Development/Languages/Perl
14 Source0:        http://search.cpan.org/CPAN/authors/id/E/EE/EESTABROO/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  28e46f1991d2a26e54c8593487a14c27
16 URL:            http://search.cpan.org/dist/Passwd-Linux/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Passwd::Linux provides additional password routines. It augments the
23 getpw* functions with setpwinfo, modpwinfo, rmpwnam, mgetpwnam. You
24 need to run most of the functions as root or as someone who has
25 permission to modify the shadow file.
26
27 %description -l pl.UTF-8
28 Passwd::Linux dostarcza dodatkowych metod obsługi haseł. Powiększa
29 funkcje getpw* o setpwinfo, modpwinfo, rmpwnam, mgetpwnam. Większość
30 tych funkcji musi być uruchomiona z uprawnieniami roota lub osoby
31 mającej uprawnienia do modyfikacji pliku shadow.
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}-%{version}
35
36 %build
37 %{__perl} Makefile.PL \
38         INSTALLDIRS=vendor
39 %{__make} \
40         CC="%{__cc}" \
41         OPTIMIZE="%{rpmcflags}"
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} pure_install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Passwd/Linux/.packlist
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes
59 %dir %{perl_vendorarch}/Passwd
60 %{perl_vendorarch}/Passwd/*.pm
61 %dir %{perl_vendorarch}/auto/Passwd
62 %dir %{perl_vendorarch}/auto/Passwd/Linux
63 %attr(755,root,root) %{perl_vendorarch}/auto/Passwd/Linux/*.so
64 %{_mandir}/man3/*
This page took 0.180163 seconds and 3 git commands to generate.