]> git.pld-linux.org Git - packages/perl-Parse-RecDescent.git/blob - perl-Parse-RecDescent.spec
78d06f3b5ebac284f8d57bae16f0dd89a519b862
[packages/perl-Parse-RecDescent.git] / perl-Parse-RecDescent.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Parse
7 %define         pnam    RecDescent
8 Summary:        Parse::RecDescent - generate recursive-descent parsers
9 Summary(pl.UTF-8):      Parse::RecDescent - generowanie zmniejszających rekurencyjnie analizatorów
10 Name:           perl-Parse-RecDescent
11 Version:        1.967013
12 Release:        1
13 License:        Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Parse/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  98f582240556a4a92e5d57e480f9d39d
17 URL:            http://search.cpan.org/dist/Parse-RecDescent/
18 BuildRequires:  perl-Text-Balanced
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 # these versions included own copy of Text::Balanced
22 BuildConflicts: perl-Parse-RecDescent < 1.92
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _noautoreq      'perl(Calc)'
27
28 %description
29 RecDescent incrementally generates top-down recursive-descent text
30 parsers from simple yacc-like grammar specifications. It provides:
31 - Regular expressions or literal strings as terminals (tokens),
32 - Multiple (non-contiguous) productions for any rule,
33 - Repeated, optional and alternate subrules within productions,
34 - Late-bound (run-time dispatched) subrules,
35 - Full access to Perl within actions specified as part of the grammar,
36 - Simple automated error reporting during parser generation and
37   parsing,
38 - The ability to commit to, uncommit to, or reject particular
39   productions during a parse,
40 - Incremental extension of the parsing grammar (even during a parse),
41 - Precompilation of parser objects,
42 - User-definable reduce-reduce conflict resolution via "scoring" of
43   matching productions.
44
45 %description -l pl.UTF-8
46 RecDescent generuje przyrostowo zstępujące, zmniejszające
47 rekurencyjnie analizatory tekstu w oparciu o prostą specyfikację
48 gramatyki, podobną do używanej przez yacca. Udostępnia on:
49 - Wyrażenia regularne i łańcuchy literałów jako terminale (tokeny),
50 - Wielokrotną (nieciągłą) produkcję dla każdej reguły,
51 - Powtarzane, opcjonalne i alternatywne podreguły w obrębie produkcji,
52 - Podreguły późnego wiązania (wysyłane w chwili uruchomienia),
53 - Pełen dostęp do Perla w obrębie akcji określonych jako część
54   gramatyki,
55 - Proste, zautomatyzowane sygnalizowanie błędów podczas generacji
56   analizatora i podczas analizy,
57 - Możliwość zatwierdzenia, cofnięcia oraz odrzucania poszczególnych
58   produkcji podczas analizy,
59 - Przyrostowe rozszerzanie gramatyki podlegającej analizie (nawet
60   podczas samej analizy),
61 - Prekompilację obiektów analizatora,
62 - Definiowalne przez użytkownika rozpoznawanie konfliktów
63   "reduce-reduce" poprzez ocenianie dopasowania produkcji.
64
65 %prep
66 %setup -q -n %{pdir}-%{pnam}-%{version}
67
68 %build
69 %{__perl} Makefile.PL \
70         INSTALLDIRS=vendor
71 %{__make}
72
73 %{?with_tests:%{__make} test}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77
78 %{__make} pure_install \
79         DESTDIR=$RPM_BUILD_ROOT
80
81 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Parse/RecDescent/.packlist
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %doc README Changes
89 %{perl_vendorlib}/Parse/RecDescent.pm
90 %{_mandir}/man3/Parse::RecDescent.3pm*
This page took 0.053134 seconds and 2 git commands to generate.